# CVE-2026-52834: jxl-oxide: Out-of-bounds writes due to integer overflow in jxl-grid on 32-bit platforms

> Integer overflow in jxl-grid allows out-of-bounds writes during JPEG XL decoding on 32-bit platforms, leading to code execution or crashes.

- **Severity:** High 7.3 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-5pmv-rx8r-wmv5, RUSTSEC-2026-0151

## What is CVE-2026-52834?

CVE-2026-52834 is a high-severity vulnerability in tirr-c jxl-grid, published on 19 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

jxl-oxide is a pure Rust implementation of a JPEG XL decoder. Prior to jxl-grid 0.6.2, decoding a crafted JPEG XL image on a 32-bit platform can overflow length calculations in AlignedGrid::with_alloc_tracker and related grid and subgrid arithmetic. A 65536 x 65536 frame can pass the frame-area limit while overflowing the usize element count, causing modular, VarDCT, or filter rendering paths to allocate a backing buffer smaller than the logical grid. A tiny bitstream-controlled cropped frame combined with a huge canvas or requested region can also reach the vulnerable composition path in crates/jxl-render/src/blend.rs through ordinary render_frame(). Later mutable subgrid and raw-pointer operations can then perform attacker-controlled out-of-bounds writes, causing memory corruption, denial of service, or arbitrary code execution. This issue is fixed in jxl-grid version 0.6.2.

Weakness: CWE-190 (Integer Overflow or Wraparound), CWE-131 (Incorrect Calculation of Buffer Size), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-52834?

3 open source packages ship an affected version, including jxl-grid.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jxl-grid` | crates.io | All versions | 0.6.2 |
| `jxl-grid` | crates.io | All versions | 0.6.2 |
| `jxl-grid` | crates.io | From 0.0.0-0 | 0.6.2 |

## How do I fix CVE-2026-52834?

Upgrade jxl-grid to 0.6.2 or later.

## Is CVE-2026-52834 being exploited?

There is no known exploitation of CVE-2026-52834 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52834 and fix it if it is affected.

What it is: CVE-2026-52834 is a high-severity vulnerability in tirr-c jxl-grid, published on 19 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-52834 in the wild and no public exploit code.

Affected packages and fixed versions:
- jxl-grid (crates.io): affected all versions; fixed in 0.6.2
- jxl-grid (crates.io): affected all versions; fixed in 0.6.2
- jxl-grid (crates.io): affected from 0.0.0-0; fixed in 0.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52834/ (Markdown: https://insights.sbomify.com/CVE-2026-52834/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52834
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52834
- OSV: https://osv.dev/vulnerability/CVE-2026-52834

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52834/
Summaries are generated and may contain mistakes; the official description above is the record.
