# CVE-2026-52836: Denial of service in OpenDDS

> A remote attacker can crash OpenDDS participants by sending malformed RTPS UDP submessages, causing a denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-wcr7-gccq-vv56

## What is CVE-2026-52836?

CVE-2026-52836 is a high-severity denial of service vulnerability in OpenDDS, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenDDS is an open source C++ implementation of the Object Management Group (OMG) Data Distribution Service (DDS). Prior to 3.34.0, a network attacker can crash a reachable OpenDDS participant by sending a malformed RTPS UDP submessage whose crafted length or sequence-number state causes dds/DCPS/transport/rtps_udp/RtpsUdpReceiveStrategy.cpp in RtpsUdpReceiveStrategy::handle_input() to advance ACE_Message_Block::rd_ptr() beyond valid data. The parser can then call dds/DCPS/transport/rtps_udp/RtpsSampleHeader.cpp in RtpsSampleHeader::init(), which dereferences the invalid read pointer without first validating it against wr_ptr() or ensuring that a complete submessage header remains. The resulting SIGSEGV occurs in the receive thread, terminates the DDS process, and destroys the DDS entities hosted by that participant. No authentication, prior protocol state, or victim interaction is required. This issue is fixed in version 3.34.0.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-52836?


## How do I fix CVE-2026-52836?

No fix has been published for CVE-2026-52836 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-52836 being exploited?

There is no known exploitation of CVE-2026-52836 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52836 and fix it if it is affected.

What it is: CVE-2026-52836 is a high-severity denial of service vulnerability in OpenDDS, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-52836 in the wild and no public exploit code.

Affected product: OpenDDS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52836/ (Markdown: https://insights.sbomify.com/CVE-2026-52836/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52836
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52836
- OSV: https://osv.dev/vulnerability/CVE-2026-52836

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52836/
Summaries are generated and may contain mistakes; the official description above is the record.
