{"answers":{"affected":"2 open source packages ship an affected version, including alextselegidis/easyappointments.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52839 exists.","fix":"Upgrade alextselegidis/easyappointments to 1.6.0 or later.","what":"CVE-2026-52839 is a low-severity missing authorization vulnerability in alextselegidis easyappointments, published on 14 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-52839 and fix it if it is affected.\n\nWhat it is: CVE-2026-52839 is a low-severity missing authorization vulnerability in alextselegidis easyappointments, published on 14 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52839 exists.\n\nAffected packages and fixed versions:\n- alextselegidis/easyappointments (Packagist): affected all versions; fixed in 1.6.0\n- alextselegidis/easyappointments (Packagist): affected all versions; fixed in 1.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-52839/ (Markdown: https://insights.sbomify.com/CVE-2026-52839/index.md)","id":"CVE-2026-52839","markdown":"https://insights.sbomify.com/CVE-2026-52839/index.md","name":"CVE-2026-52839","record":{"aliases":["GHSA-w8xc-8g92-v77h"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Appointment scheduling software","requires_auth":"high_privilege","summary":"Authenticated providers can inject or reassign appointments to other providers' schedules due to missing ownership checks in mutation endpoints.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3.3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"}],"description":"Easy!Appointments is a self hosted appointment scheduler. Versions prior to 1.6.0 correctly filter provider-scoped appointments in the `appointments/search` response, proving that provider isolation is an intended security boundary. However, the direct mutation endpoints `appointments/store` and `appointments/update` only check generic appointment privileges and never verify that the submitted `id_users_provider` belongs to the current session. A normal authenticated provider can inject new appointments into another provider's schedule via `store`, or reassign existing appointments into a foreign provider's calendar via `update`. The `store` path contains an additional write-before-crash bug: the unauthorized row is committed to the database before the controller crashes on a type error, so the attacker receives an error response while the foreign appointment is already persisted. Version 1.6.0 patches the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Easy!Appointments appointments/store and appointments/update allow cross-provider appointment injection — Authorization Bypass","id":"CVE-2026-52839","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Easy!Appointments has server-side request forgery in CalDAV connection test that exposes the deployment's internal network","id":"CVE-2026-52840"},"packages":[{"ecosystem":"Packagist","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"alextselegidis/easyappointments","purl":null,"source":"GHSA-w8xc-8g92-v77h"},{"ecosystem":"Packagist","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"alextselegidis/easyappointments","purl":"pkg:composer/alextselegidis/easyappointments","source":"GHSA-w8xc-8g92-v77h"}],"prev":{"headline":"Easy!Appointments disable_booking_message rendered as raw HTML on public booking page — Stored XSS","id":"CVE-2026-52838"},"products":["easyappointments"],"published":"2026-07-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-29","vendors":["alextselegidis"]},"summary":"Authenticated providers can inject or reassign appointments to other providers' schedules due to missing ownership checks in mutation endpoints.","url":"https://insights.sbomify.com/CVE-2026-52839/"}