# CVE-2026-52839: Easy!Appointments appointments/store and appointments/update allow cross-provider appointment injection — Authorization Bypass

> Authenticated providers can inject or reassign appointments to other providers' schedules due to missing ownership checks in mutation endpoints.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-w8xc-8g92-v77h

## What is CVE-2026-52839?

CVE-2026-52839 is a low-severity missing authorization vulnerability in alextselegidis easyappointments, published on 14 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Easy!Appointments is a self hosted appointment scheduler. Versions prior to 1.6.0 correctly filter provider-scoped appointments in the `appointments/search` response, proving that provider isolation is an intended security boundary. However, the direct mutation endpoints `appointments/store` and `appointments/update` only check generic appointment privileges and never verify that the submitted `id_users_provider` belongs to the current session. A normal authenticated provider can inject new appointments into another provider's schedule via `store`, or reassign existing appointments into a foreign provider's calendar via `update`. The `store` path contains an additional write-before-crash bug: the unauthorized row is committed to the database before the controller crashes on a type error, so the attacker receives an error response while the foreign appointment is already persisted. Version 1.6.0 patches the issue.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-52839?

2 open source packages ship an affected version, including alextselegidis/easyappointments.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `alextselegidis/easyappointments` | Packagist | All versions | 1.6.0 |
| `alextselegidis/easyappointments` | Packagist | All versions | 1.6.0 |

## How do I fix CVE-2026-52839?

Upgrade alextselegidis/easyappointments to 1.6.0 or later.

## Is CVE-2026-52839 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52839 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52839 and fix it if it is affected.

What it is: CVE-2026-52839 is a low-severity missing authorization vulnerability in alextselegidis easyappointments, published on 14 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52839 exists.

Affected packages and fixed versions:
- alextselegidis/easyappointments (Packagist): affected all versions; fixed in 1.6.0
- alextselegidis/easyappointments (Packagist): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52839/ (Markdown: https://insights.sbomify.com/CVE-2026-52839/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52839
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52839
- OSV: https://osv.dev/vulnerability/CVE-2026-52839

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52839/
Summaries are generated and may contain mistakes; the official description above is the record.
