# CVE-2026-52845: Caddy: FastCGI header normalization bypass in `forward_auth copy_headers`

> Remote attackers can bypass forward authentication checks by exploiting header normalization differences, allowing them to inject trusted identity headers into PHP/FastCGI applications.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-DI50489, DEBIAN-CVE-2026-52845, GHSA-f59h-q822-g45g, GO-2026-5346, MINI-9236-f2jv-m5g5, MINI-9jhw-j2hq-p4vc, UBUNTU-CVE-2026-52845

## What is CVE-2026-52845?

CVE-2026-52845 is a high-severity authentication bypass vulnerability in caddyserver caddy, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, forward_auth copy_headers deletes the exact client-supplied identity header before copying the trusted value from the auth gateway. But when the request later goes through php_fastcgi, Caddy normalizes HTTP headers into CGI variables by replacing - with _. This lets a client send an underscore alias that survives the forward_auth delete step but becomes the same PHP/FastCGI variable. Result: a remote client can inject or sometimes override identity/group headers trusted by PHP/FastCGI applications behind Caddy. This vulnerability is fixed in 2.11.4.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests), CWE-290 (Authentication Bypass by Spoofing), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-52845?

5 open source packages ship an affected version, including github.com/caddyserver/caddy/v2 and github.com/caddyserver/caddy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/caddyserver/caddy/v2` | Go | All versions | 2.11.4 |
| `github.com/caddyserver/caddy/v2` | Go | All versions | 2.11.4 |
| `github.com/caddyserver/caddy/v2` | Go | All versions | 2.11.4 |
| `github.com/caddyserver/caddy` | Go | All versions to 1.0.5 | None |
| `github.com/caddyserver/caddy` | Go | All versions to 1.0.5 | None |

Products: Caddyserver Caddy.

## How do I fix CVE-2026-52845?

Upgrade github.com/caddyserver/caddy/v2 to 2.11.4 or later.

## Is CVE-2026-52845 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52845 exists.

## Other vulnerabilities in caddyserver caddy

- [CVE-2018-21246](https://insights.sbomify.com/CVE-2018-21246/): Caddy vulnerable to Authentication Bypass due to mishandling of TLS client authentication (critical 9.8)
- [CVE-2026-27590](https://insights.sbomify.com/CVE-2026-27590/): Caddy: Unicode case-folding length expansion causes incorrect split_path index in FastCGI transport (high 8.9)
- [CVE-2026-27586](https://insights.sbomify.com/CVE-2026-27586/): Caddy's mTLS client authentication silently fails open when CA certificate file is missing or malformed (high 8.8)
- [CVE-2026-45135](https://insights.sbomify.com/CVE-2026-45135/): Caddy: Unsafe Unicode Handling in FastCGI splitPos Allows Execution of Non-PHP Files (high 8.1)
- [CVE-2026-30851](https://insights.sbomify.com/CVE-2026-30851/): Caddy forward_auth copy_headers Does Not Strip Client-Supplied Headers, Allowing Identity Injection and Privilege Escalation (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52845 and fix it if it is affected.

What it is: CVE-2026-52845 is a high-severity authentication bypass vulnerability in caddyserver caddy, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52845 exists.

Affected packages and fixed versions:
- github.com/caddyserver/caddy/v2 (Go): affected all versions; fixed in 2.11.4
- github.com/caddyserver/caddy/v2 (Go): affected all versions; fixed in 2.11.4
- github.com/caddyserver/caddy/v2 (Go): affected all versions; fixed in 2.11.4
- github.com/caddyserver/caddy (Go): affected all versions up to 1.0.5; no fix listed
- github.com/caddyserver/caddy (Go): affected all versions up to 1.0.5; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52845/ (Markdown: https://insights.sbomify.com/CVE-2026-52845/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52845
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52845
- OSV: https://osv.dev/vulnerability/CVE-2026-52845

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52845/
Summaries are generated and may contain mistakes; the official description above is the record.
