# CVE-2026-52846: Caddy: stripHTML template function bypass

> Attackers can bypass HTML stripping to inject malicious scripts, leading to client-side XSS when untrusted data is rendered.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** CLEANSTART-2026-UL03599, DEBIAN-CVE-2026-52846, GHSA-vcc4-2c75-vc9v, GO-2026-5660, MINI-p8cr-c9wg-wrmw, MINI-qvjv-hmf9-m25g, UBUNTU-CVE-2026-52846

## What is CVE-2026-52846?

CVE-2026-52846 is a medium-severity cross-site scripting vulnerability in caddyserver caddy, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, Caddy’s stripHTML template function cannot reliably remove all HTML tags from input strings. Certain malformed HTML, such as <<>img src=x onerror=alert()>, can bypass the tag-stripping logic, potentially leaving dangerous content in the output if it is later rendered as HTML. This may allow client-side XSS in cases where untrusted strings are rendered unsafely. This vulnerability is fixed in 2.11.4.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-52846?

5 open source packages ship an affected version, including github.com/caddyserver/caddy/v2 and github.com/caddyserver/caddy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/caddyserver/caddy/v2` | Go | All versions | 2.11.4 |
| `github.com/caddyserver/caddy/v2` | Go | All versions | 2.11.4 |
| `github.com/caddyserver/caddy/v2` | Go | All versions | 2.11.4 |
| `github.com/caddyserver/caddy` | Go | All versions to 1.0.5 | None |
| `github.com/caddyserver/caddy` | Go | All versions to 1.0.5 | None |

Products: Caddyserver Caddy.

## How do I fix CVE-2026-52846?

Upgrade github.com/caddyserver/caddy/v2 to 2.11.4 or later.

## Is CVE-2026-52846 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52846 exists.

## Other vulnerabilities in caddyserver caddy

- [CVE-2018-21246](https://insights.sbomify.com/CVE-2018-21246/): Caddy vulnerable to Authentication Bypass due to mishandling of TLS client authentication (critical 9.8)
- [CVE-2026-27590](https://insights.sbomify.com/CVE-2026-27590/): Caddy: Unicode case-folding length expansion causes incorrect split_path index in FastCGI transport (high 8.9)
- [CVE-2026-27586](https://insights.sbomify.com/CVE-2026-27586/): Caddy's mTLS client authentication silently fails open when CA certificate file is missing or malformed (high 8.8)
- [CVE-2026-45135](https://insights.sbomify.com/CVE-2026-45135/): Caddy: Unsafe Unicode Handling in FastCGI splitPos Allows Execution of Non-PHP Files (high 8.1)
- [CVE-2026-52845](https://insights.sbomify.com/CVE-2026-52845/): Caddy: FastCGI header normalization bypass in `forward_auth copy_headers` (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52846 and fix it if it is affected.

What it is: CVE-2026-52846 is a medium-severity cross-site scripting vulnerability in caddyserver caddy, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52846 exists.

Affected packages and fixed versions:
- github.com/caddyserver/caddy/v2 (Go): affected all versions; fixed in 2.11.4
- github.com/caddyserver/caddy/v2 (Go): affected all versions; fixed in 2.11.4
- github.com/caddyserver/caddy/v2 (Go): affected all versions; fixed in 2.11.4
- github.com/caddyserver/caddy (Go): affected all versions up to 1.0.5; no fix listed
- github.com/caddyserver/caddy (Go): affected all versions up to 1.0.5; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52846/ (Markdown: https://insights.sbomify.com/CVE-2026-52846/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52846
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52846
- OSV: https://osv.dev/vulnerability/CVE-2026-52846

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52846/
Summaries are generated and may contain mistakes; the official description above is the record.
