{"answers":{"affected":"2 open source packages ship an affected version, including mediawiki/maps.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52854 exists.","fix":"Upgrade mediawiki/maps to 12.1.3 or later.","what":"CVE-2026-52854 is a high-severity cross-site scripting vulnerability in ProfessionalWiki Maps, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-52854 and fix it if it is affected.\n\nWhat it is: CVE-2026-52854 is a high-severity cross-site scripting vulnerability in ProfessionalWiki Maps, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52854 exists.\n\nAffected packages and fixed versions:\n- mediawiki/maps (Packagist): affected all versions; fixed in 12.1.3\n- mediawiki/maps (Packagist): affected all versions; fixed in 12.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-52854/ (Markdown: https://insights.sbomify.com/CVE-2026-52854/index.md)","id":"CVE-2026-52854","markdown":"https://insights.sbomify.com/CVE-2026-52854/index.md","name":"CVE-2026-52854","record":{"aliases":["GHSA-4h7g-5542-v3fc","UBUNTU-CVE-2026-52854"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki Maps extension","requires_auth":"none","summary":"A stored XSS vulnerability in the MediaWiki Maps extension allows attackers to execute scripts in viewers' browsers via the overlays parameter.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Maps is a MediaWiki extension that enables visualization of geographic data through dynamic embedded maps. Prior to version 12.1.3, the display_map parser function in the Leaflet service accepts attacker-controlled HTML in the overlays parameter, and resources/leaflet/jquery.leaflet.js uses the overlay name as a Leaflet layer-control label without escaping it. A wiki user with the edit permission can store malicious wikitext that causes script execution when another user previews or views the affected map. The script executes in the viewing user's browser session and can access data or perform actions available to that user. This issue is fixed in version 12.1.3.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"mediawiki/maps: Stored XSS through the overlays parameter in the display_map parser function","id":"CVE-2026-52854","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":5,"next":{"headline":"Wings exposes node configuration secrets through egg configuration-file templating","id":"CVE-2026-52855"},"packages":[{"ecosystem":"Packagist","fixed":["12.1.3"],"introduced":["0"],"last_affected":[],"package":"mediawiki/maps","purl":null,"source":"GHSA-4h7g-5542-v3fc"},{"ecosystem":"Packagist","fixed":["12.1.3"],"introduced":["0"],"last_affected":[],"package":"mediawiki/maps","purl":"pkg:composer/mediawiki/maps","source":"GHSA-4h7g-5542-v3fc"}],"prev":{"headline":"Docmost: Privilege Escalation - ADMIN Can Invite Users as OWNER","id":"CVE-2026-52853"},"products":["Maps"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-19","vendors":["ProfessionalWiki"]},"summary":"A stored XSS vulnerability in the MediaWiki Maps extension allows attackers to execute scripts in viewers' browsers via the overlays parameter.","url":"https://insights.sbomify.com/CVE-2026-52854/"}