# CVE-2026-52854: mediawiki/maps: Stored XSS through the overlays parameter in the display_map parser function

> A stored XSS vulnerability in the MediaWiki Maps extension allows attackers to execute scripts in viewers' browsers via the overlays parameter.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-4h7g-5542-v3fc, UBUNTU-CVE-2026-52854

## What is CVE-2026-52854?

CVE-2026-52854 is a high-severity cross-site scripting vulnerability in ProfessionalWiki Maps, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Maps is a MediaWiki extension that enables visualization of geographic data through dynamic embedded maps. Prior to version 12.1.3, the display_map parser function in the Leaflet service accepts attacker-controlled HTML in the overlays parameter, and resources/leaflet/jquery.leaflet.js uses the overlay name as a Leaflet layer-control label without escaping it. A wiki user with the edit permission can store malicious wikitext that causes script execution when another user previews or views the affected map. The script executes in the viewing user's browser session and can access data or perform actions available to that user. This issue is fixed in version 12.1.3.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-52854?

2 open source packages ship an affected version, including mediawiki/maps.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/maps` | Packagist | All versions | 12.1.3 |
| `mediawiki/maps` | Packagist | All versions | 12.1.3 |

## How do I fix CVE-2026-52854?

Upgrade mediawiki/maps to 12.1.3 or later.

## Is CVE-2026-52854 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52854 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52854 and fix it if it is affected.

What it is: CVE-2026-52854 is a high-severity cross-site scripting vulnerability in ProfessionalWiki Maps, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52854 exists.

Affected packages and fixed versions:
- mediawiki/maps (Packagist): affected all versions; fixed in 12.1.3
- mediawiki/maps (Packagist): affected all versions; fixed in 12.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52854/ (Markdown: https://insights.sbomify.com/CVE-2026-52854/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52854
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52854
- OSV: https://osv.dev/vulnerability/CVE-2026-52854

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52854/
Summaries are generated and may contain mistakes; the official description above is the record.
