# CVE-2026-52856: Wings: Maliciously crafted packet during SFTP connection handshake causes denial of service

> A malformed packet during SFTP handshake causes a panic in Wings, leading to denial of service for game server management.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-ghrq-5wpp-hxx5, GO-2026-6156

## What is CVE-2026-52856?

CVE-2026-52856 is a high-severity denial of service vulnerability in pterodactyl wings, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Wings is the server control plane for Pterodactyl, a free, open-source game server management panel. Prior to 1.13.0, a malformed packet received during the SFTP connection handshake causes a Go panic. This issue is fixed in version 1.13.0.

Weakness: CWE-617 (Reachable Assertion), CWE-248 (Uncaught Exception), CWE-755 (Improper Handling of Exceptional Conditions), CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-52856?

3 open source packages ship an affected version, including github.com/pterodactyl/wings.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pterodactyl/wings` | Go | All versions | 1.13.0 |
| `github.com/pterodactyl/wings` | Go | All versions | 1.13.0 |
| `github.com/pterodactyl/wings` | Go | All versions | 1.13.0 |

## How do I fix CVE-2026-52856?

Upgrade github.com/pterodactyl/wings to 1.13.0 or later.

## Is CVE-2026-52856 being exploited?

There is no known exploitation of CVE-2026-52856 in the wild and no public exploit code.

Public exploit code:

- PoC For CVE-2026-52856 (github_poc): https://github.com/lisbickq/CVE-2026-52856-PoC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-52856 and fix it if it is affected.

What it is: CVE-2026-52856 is a high-severity denial of service vulnerability in pterodactyl wings, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-52856 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.13.0
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.13.0
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-52856/ (Markdown: https://insights.sbomify.com/CVE-2026-52856/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-52856
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-52856
- OSV: https://osv.dev/vulnerability/CVE-2026-52856

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-52856/
Summaries are generated and may contain mistakes; the official description above is the record.
