{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-52858 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-52858 is a high-severity code injection vulnerability in Vim Vim, published on 11 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-52858 and fix it if it is affected.\n\nWhat it is: CVE-2026-52858 is a high-severity code injection vulnerability in Vim Vim, published on 11 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-52858 in the wild and no public exploit code.\n\nAffected product: Vim Vim. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-52858/ (Markdown: https://insights.sbomify.com/CVE-2026-52858/index.md)","id":"CVE-2026-52858","markdown":"https://insights.sbomify.com/CVE-2026-52858/index.md","name":"CVE-2026-52858","record":{"aliases":["ALPINE-CVE-2026-52858","AZL-89781","BELL-CVE-2026-52858","CLSA-2026-1782152616","CLSA-2026-1782153265","DEBIAN-CVE-2026-52858","ECHO-c2a9-cb6f-d4b0","GHSA-52mc-rq6p-rc7c","MINI-vr9g-9j97-64h5","ROOT-OS-DEBIAN-11-CVE-2026-52858","ROOT-OS-DEBIAN-12-CVE-2026-52858","UBUNTU-CVE-2026-52858"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Vim text editor","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code by tricking users into opening malicious Python files and triggering omni-completion in Vim.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vim","vendor":"vim"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-95","name":"Improper Neutralization of Directives in Dynamically Evaluated Code"},{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"}],"description":"Vim is an open source, command line text editor. Prior to version 9.2.0561, the Python omni-completion script in python3complete.vim for Vim with the +python3 interpreter enabled (and the legacy pythoncomplete.vim for builds with the +python interpreter) executes the import and from statements found in the current buffer through Python's import machinery. Because the buffer's working directory is on sys.path, opening a hostile .py file with a sibling Python package and invoking omni-completion runs that package's top-level code as the editing user. This issue has been patched in version 9.2.0561.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Vim: Arbitrary Code Execution via Python Omni-Completion","id":"CVE-2026-52858","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"vim:vim","products":["vim:vim"],"type":"code_injection","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Vim: Out-of-bounds Read in Terminal Screen Snapshot","id":"CVE-2026-52859"},"packages":[],"prev":{"headline":"Wings: Maliciously or erroneously created parsed config files can cause wings process to OOM","id":"CVE-2026-52857"},"products":["vim"],"published":"2026-06-11","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2020-20703","kev_date_added":null,"published":"2023-06-20"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-6349","kev_date_added":null,"published":"2017-02-27"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-6350","kev_date_added":null,"published":"2017-02-27"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-5953","kev_date_added":null,"published":"2017-02-10"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-3075","kev_date_added":null,"published":"2009-02-21"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-3076","kev_date_added":null,"published":"2009-02-21"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-6235","kev_date_added":null,"published":"2009-02-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-12","vendors":["vim"]},"summary":"Attackers can execute arbitrary code by tricking users into opening malicious Python files and triggering omni-completion in Vim.","url":"https://insights.sbomify.com/CVE-2026-52858/"}