{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-52860 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-52860 is a high-severity code injection vulnerability in Vim Vim, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-52860 and fix it if it is affected.\n\nWhat it is: CVE-2026-52860 is a high-severity code injection vulnerability in Vim Vim, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-52860 in the wild and no public exploit code.\n\nAffected product: Vim Vim. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-52860/ (Markdown: https://insights.sbomify.com/CVE-2026-52860/index.md)","id":"CVE-2026-52860","markdown":"https://insights.sbomify.com/CVE-2026-52860/index.md","name":"CVE-2026-52860","record":{"aliases":["ALPINE-CVE-2026-52860","AZL-89769","BELL-CVE-2026-52860","CLSA-2026-1782299449","CLSA-2026-1782299648","DEBIAN-CVE-2026-52860","ECHO-1ae5-1aa8-8736","MINI-pqx8-r5v5-cpc2","ROOT-OS-DEBIAN-11-CVE-2026-52860","ROOT-OS-DEBIAN-12-CVE-2026-52860","UBUNTU-CVE-2026-52860"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Vim text editor","requires_auth":"none","summary":"Attackers can execute arbitrary code by crafting a hostile buffer that triggers Python omni-completion in Vim, requiring users to upgrade to the patched version.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vim","vendor":"vim"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Vim is an open source, command line text editor. Prior to version 9.2.0597, Vim's Python omni-completion executes reconstructed function and class definitions from the current buffer with exec() as part of populating the completion dictionary. Python evaluates function default values, parameter annotations, and class base expressions at definition time, so a hostile buffer can execute attacker-controlled Python expressions during omni-completion. The existing g:pythoncomplete_allow_import mitigation (GHSA-52mc-rq6p-rc7c) does not cover this path, because the attacker-controlled code is not a harvested import/from statement. This issue has been patched in version 9.2.0597.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Vim: Arbitrary Code Execution via Python Omni-Completion","id":"CVE-2026-52860","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"vim:vim","products":["vim:vim"],"type":"code_injection","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"Memory corruption could lead to crash and denial of service","id":"CVE-2026-52863"},"packages":[],"prev":{"headline":"Vim: Out-of-bounds Read in Terminal Screen Snapshot","id":"CVE-2026-52859"},"products":["vim"],"published":"2026-06-11","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2020-20703","kev_date_added":null,"published":"2023-06-20"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-6349","kev_date_added":null,"published":"2017-02-27"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-6350","kev_date_added":null,"published":"2017-02-27"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-5953","kev_date_added":null,"published":"2017-02-10"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-3075","kev_date_added":null,"published":"2009-02-21"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-3076","kev_date_added":null,"published":"2009-02-21"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-6235","kev_date_added":null,"published":"2009-02-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["vim"]},"summary":"Attackers can execute arbitrary code by crafting a hostile buffer that triggers Python omni-completion in Vim, requiring users to upgrade to the patched version.","url":"https://insights.sbomify.com/CVE-2026-52860/"}