CVE-2026-52879 Klever-Go: Unbounded goroutine spawn on direct-message ingress enables peer-driven DoS
A remote attacker can cause denial of service in Klever-Go nodes by sending direct messages that trigger unbounded goroutine creation, exhausting system resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-52879?
CVE-2026-52879 is a high-severity denial of service vulnerability in klever-io klever-go, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Klever-Go is the Go implementation of the Klever blockchain protocol. In versions 1.7.14 through 1.7.17, the direct-message ingress handler spawns a new goroutine for every incoming direct message before the processor-level antiflood layer makes any admission decision, with no semaphore, throttler, or bound on the number of concurrent in-flight spawns. Because the antiflood check runs inside the spawned goroutine rather than before it, a single connected peer can open a direct-send stream and send a stream of well-formed messages to force unbounded goroutine creation, where each goroutine allocates its own stack and holds a message reference until processing completes, adding scheduler and garbage-collection pressure faster than the runtime can drain it. This lets one peer degrade the node's availability and its ability to process legitimate traffic, resulting in a remotely triggerable denial of service. The issue is fixed in 1.7.18.
Which versions are affected by CVE-2026-52879?
3 open source packages ship an affected version, including github.com/klever-io/klever-go.
| Package | Affected | Fixed in |
|---|---|---|
github.com/klever-io/klever-go Go | From 1.7.14 | 1.7.18 |
github.com/klever-io/klever-go Go | From 1.7.14 | 1.7.18 |
github.com/klever-io/klever-go Go | From 1.7.14 | 1.7.18 |
How do I fix CVE-2026-52879?
Upgrade github.com/klever-io/klever-go to 1.7.18 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-52879 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52879 exists.
Sources
Also known as GHSA-hf2g-6j7h-98wg, GO-2026-5424.