CVE-2026-52880 Klever-Go: REST API slow-header connection exhaustion via Gin Engine.Run
Unauthenticated attackers can exhaust server file descriptors via slow-header connections, causing denial of service for the REST API.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-52880?
CVE-2026-52880 is a high-severity denial of service vulnerability in klever-io klever-go, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Klever-Go is the Go implementation of the Klever blockchain protocol. Versions from 1.7.14 through 1.7.17 are vulnerable to a remotely triggerable denial of service. Both REST APIs are started with the Gin Engine.Run convenience method, which serves requests through Go's default HTTP server with no ReadHeaderTimeout, ReadTimeout, or MaxHeaderBytes configured. As a result, incoming connections that never complete their request headers are held open indefinitely. When a REST listener is reachable beyond localhost through the documented all-interface bind or a Docker port-publish deployment, a single unauthenticated client can open many slow-header connections and hold them open until server file descriptors are exhausted, preventing the API from accepting new connections. This renders the REST API unavailable to legitimate clients. This issue is fixed in version 1.7.18.
Which versions are affected by CVE-2026-52880?
3 open source packages ship an affected version, including github.com/klever-io/klever-go.
| Package | Affected | Fixed in |
|---|---|---|
github.com/klever-io/klever-go Go | From 1.7.14 | 1.7.18 |
github.com/klever-io/klever-go Go | From 1.7.14 | 1.7.18 |
github.com/klever-io/klever-go Go | From 1.7.14 | 1.7.18 |
How do I fix CVE-2026-52880?
Upgrade github.com/klever-io/klever-go to 1.7.18 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-52880 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-52880 exists.
Sources
Also known as GHSA-w4c6-7r69-w7j9, GO-2026-5686.