CVE-2026-5308 Missing request body size limits on Zoom plugin HTTP endpoints
Attackers can cause denial of service by sending oversized HTTP requests to Mattermost plugin endpoints due to missing body size limits.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-5308?
CVE-2026-5308 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 22 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to enforce request body size limits on plugin HTTP endpoints which allows an attacker to cause a denial of service via crafted oversized HTTP requests.. Mattermost Advisory ID: MMSA-2026-00646
Weakness: CWE-400
Which versions are affected by CVE-2026-5308?
12 open source packages ship an affected version, including github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-plugin-github. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.15 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.15 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.15+incompatible, 11.4.5+incompatible, 11.5.4+incompatible, 11.6.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.4.0 | 11.4.5 |
github.com/mattermost/mattermost-server Go | From 11.4.0 | 11.4.5 |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.4 |
6 more packages
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.4 |
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.1 |
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.1 |
github.com/mattermost/mattermost-plugin-github Go | All versions | 1.0.1-0.20260410143745-9b41b1fd43c4 |
github.com/mattermost/mattermost-plugin-github Go | All versions | 1.0.1-0.20260410143745-9b41b1fd43c4 |
github.com/mattermost/mattermost-plugin-github Go | All versions | 1.0.1-0.20260410143745-9b41b1fd43c4 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-5308?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.15, 10.11.15+incompatible, 11.4.5+incompatible or 11.5.4+incompatible.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-5308 being exploited?
There is no known exploitation of CVE-2026-5308 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-jmvr-r5hm-fxfr, GO-2026-5836.