# CVE-2026-53405: Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask

> Administrators can execute arbitrary code on the server by importing and starting BPMN processes containing unsandboxed Groovy scripts.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Jul 2026
- **Updated:** 21 Jul 2026
- **Also known as:** GHSA-xvr8-rwv3-hv45

## What is CVE-2026-53405?

CVE-2026-53405 is a critical code injection vulnerability in Apache Syncope, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Isolation or Compartmentalization vulnerability in Apache Syncope.

An administrator with adequate entitlements can import arbitrary BPMN process definitions via the REST API and then start the process. When a BPMN process containing a Groovy scriptTask is imported and started, the Groovy script is executed directly on the server, with no sandbox.

This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1.

Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue by wrapping Flowable's Groovy scriptTasks with security sandbox.

Weakness: CWE-653 (Improper Isolation or Compartmentalization)

## Which versions are affected by CVE-2026-53405?

It affects 1 product.


Products: Apache Syncope.

## How do I fix CVE-2026-53405?

No fix has been published for CVE-2026-53405 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-53405 being exploited?

There is no known exploitation of CVE-2026-53405 in the wild and no public exploit code.

## Other vulnerabilities in Apache Syncope

- [CVE-2026-53421](https://insights.sbomify.com/CVE-2026-53421/): Apache Syncope: Remote Code Execution via Scripted Connector (critical 9.8)
- [CVE-2026-57308](https://insights.sbomify.com/CVE-2026-57308/): Apache Syncope: SQL injection vulnerability in Audit Events search (critical 9.8)
- [CVE-2026-62183](https://insights.sbomify.com/CVE-2026-62183/): Apache Syncope: User self-service privilege escalation (critical 9.8)
- [CVE-2026-63071](https://insights.sbomify.com/CVE-2026-63071/): Apache Syncope: RCE via Groovy Sandbox bypass (critical 9.8)
- [CVE-2020-1959](https://insights.sbomify.com/CVE-2020-1959/): Expression Language Injection in Apache Syncope (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53405 and fix it if it is affected.

What it is: CVE-2026-53405 is a critical code injection vulnerability in Apache Syncope, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53405 in the wild and no public exploit code.

Affected product: Apache Syncope. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53405/ (Markdown: https://insights.sbomify.com/CVE-2026-53405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53405
- OSV: https://osv.dev/vulnerability/CVE-2026-53405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53405/
Summaries are generated and may contain mistakes; the official description above is the record.
