CVE-2026-53421 Apache Syncope: Remote Code Execution via Scripted Connector

Critical 9.8 Published Updated

Administrators can achieve remote code execution via Groovy scripts in Apache Syncope's connector subsystem, requiring an upgrade to hardened versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-53421?

CVE-2026-53421 is a critical code injection vulnerability in Apache Syncope, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Isolation or Compartmentalization vulnerability in Apache Syncope.

An administrator with adequate entitlements can achieve remote code execution through the connector subsystem by relying on scripted connectors' (REST and SQL) capability to run Groovy scripts.

This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1.

Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue by hardening the Groovy security sandbox.

Weakness: CWE-653

Which versions are affected by CVE-2026-53421?

It affects 1 product.

Products include Apache Syncope.

How do I fix CVE-2026-53421?

No fix has been published for CVE-2026-53421 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-53421 being exploited?

There is no known exploitation of CVE-2026-53421 in the wild and no public exploit code.

Sources

Also known as GHSA-c7pj-2f8j-jc8m.

Is CVE-2026-53421 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free