# CVE-2026-53427: Cross-site scripting in MDEx via unescaped highlight_lines_class code-fence attribute

> Attackers can inject arbitrary JavaScript via Markdown code fences when specific rendering options are enabled, leading to session theft and account takeover.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jun 2026
- **Updated:** 30 Jun 2026
- **Also known as:** EEF-CVE-2026-53427, GHSA-v664-pmxr-mxxx

## What is CVE-2026-53427?

CVE-2026-53427 is a low-severity cross-site scripting vulnerability in leandrocp mdex, published on 29 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in leandrocp MDEx allows stored or reflected cross-site scripting via attacker-controlled Markdown.

When syntax highlighting and full info-string forwarding (render: [full_info_string: true]) are enabled, the Lumis adapter copies the value of a code fence's highlight_lines_class info-string attribute, unescaped, into the class attribute of every rendered line. comrak_nif::lumis_adapter::LumisAdapter::parse_custom_attributes in native/comrak_nif/src/lumis_adapter.rs shlex-parses the info string and stores each key=value pair verbatim, highlight_lines_config pulls highlight_lines_class into the per-line class value, and write_highlighted interpolates that value directly into the class attribute of the per-line <div>. A single-quoted shell token preserves an inner double quote through shlex parsing, so a value such as '"><script>alert(1)</script>' terminates the class attribute early and the markup that follows is emitted as live HTML.

An attacker who can submit Markdown (through comments, posts, wiki pages, documentation, or any user-generated content) can inject arbitrary HTML and JavaScript that runs in the browser of every user who views the rendered output, enabling session theft, account takeover, and other client-side attacks. No authentication or special privileges are required.

The vulnerable native code originally shipped inside mdex (in native/comrak_nif/src/lumis_adapter.rs) and was later extracted into the separate mdex_native package (native/mdex_native_nif/src/lumis_adapter.rs), where it remains unpatched.

This issue affects mdex from 0.11.3 before 0.12.3, and mdex_native from 0.1.0 before 0.2.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-53427?

2 open source packages ship an affected version, including mdex and mdex_native.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mdex` | Hex | From 0.11.3 | 0.12.3 |
| `mdex_native` | Hex | From 0.1.0 | 0.2.3 |

## How do I fix CVE-2026-53427?

Upgrade mdex to 0.12.3 or later.

## Is CVE-2026-53427 being exploited?

There is no known exploitation of CVE-2026-53427 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53427 and fix it if it is affected.

What it is: CVE-2026-53427 is a low-severity cross-site scripting vulnerability in leandrocp mdex, published on 29 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-53427 in the wild and no public exploit code.

Affected packages and fixed versions:
- mdex (Hex): affected from 0.11.3; fixed in 0.12.3
- mdex_native (Hex): affected from 0.1.0; fixed in 0.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53427/ (Markdown: https://insights.sbomify.com/CVE-2026-53427/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53427
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53427
- OSV: https://osv.dev/vulnerability/CVE-2026-53427

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53427/
Summaries are generated and may contain mistakes; the official description above is the record.
