# CVE-2026-53430: grpc gzip decompression bomb in GRPC.Compressor.Gzip.decompress/1

> An unauthenticated remote attacker can cause a denial of service by sending a crafted gzip-compressed gRPC frame that exhausts memory via decompression bomb.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2026
- **Updated:** 17 Jun 2026
- **Also known as:** EEF-CVE-2026-53430, GHSA-6ccx-9c9f-327w

## What is CVE-2026-53430?

CVE-2026-53430 is a high-severity denial of service vulnerability in elixir-grpc grpc, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in elixir-grpc grpc (GRPC.Compressor.Gzip, GRPC.Message modules) allows a denial of service via a gzip decompression bomb.

This vulnerability is associated with program files lib/grpc/compressor/gzip.ex, lib/grpc/message.ex and program routines 'Elixir.GRPC.Compressor.Gzip':decompress/1, 'Elixir.GRPC.Message':from_data/2.

'Elixir.GRPC.Compressor.Gzip':decompress/1 calls :zlib.gunzip/1 directly on attacker-controlled bytes with no decompressed-size limit, ratio check, or incremental decoding. Because this module is the registered gzip GRPC.Compressor implementation, it is invoked automatically whenever an incoming gRPC frame carries the grpc-encoding: gzip header. :zlib.gunzip/1 allocates the entire decompressed result as a single binary, so a small highly compressible payload (for example a few kilobytes of zeros, which gzip compresses at roughly 1000:1) expands to multiple gigabytes inside a single call. The max_receive_message_length limit is enforced only against the already-decompressed message, so it provides no protection. An unauthenticated remote peer can send a single crafted frame to exhaust the BEAM node's heap and trigger an out-of-memory kill.

This issue affects grpc: from 0.4.0 before 1.0.0.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-53430?

3 open source packages ship an affected version, including grpc.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grpc` | Hex | From 0.4.0 | 1.0.0 |
| `grpc` | Hex | From 0.4.0 | 1.0.0 |
| `grpc` | Hex | From 0.4.0 | 1.0.0 |

## How do I fix CVE-2026-53430?

Upgrade grpc to 1.0.0 or later.

## Is CVE-2026-53430 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53430 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53430 and fix it if it is affected.

What it is: CVE-2026-53430 is a high-severity denial of service vulnerability in elixir-grpc grpc, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53430 exists.

Affected packages and fixed versions:
- grpc (Hex): affected from 0.4.0; fixed in 1.0.0
- grpc (Hex): affected from 0.4.0; fixed in 1.0.0
- grpc (Hex): affected from 0.4.0; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53430/ (Markdown: https://insights.sbomify.com/CVE-2026-53430/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53430
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53430
- OSV: https://osv.dev/vulnerability/CVE-2026-53430

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53430/
Summaries are generated and may contain mistakes; the official description above is the record.
