# CVE-2026-53434: Apache Tomcat: Invalid CRL configuration doesn't trigger failure for FFM Connector

> An attacker can bypass certificate revocation checks in Apache Tomcat FFM connectors due to improper error handling in CRL configuration.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jun 2026
- **Updated:** 30 Jun 2026
- **Also known as:** BIT-tomcat-2026-53434, DEBIAN-CVE-2026-53434, GHSA-4x29-79gh-6v8q, ROOT-APP-MAVEN-CVE-2026-53434, UBUNTU-CVE-2026-53434

## What is CVE-2026-53434?

CVE-2026-53434 is a critical vulnerability in Apache Tomcat, published on 29 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Detection of Error Condition Without Action vulnerability in Apache Tomcat when configuring CRLs for a FFM based connector.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M7 through 10.1.55, from 9.0.83 through 9.0.118.

Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fixes the issue.

Weakness: CWE-390 (Detection of Error Condition Without Action)

## Which versions are affected by CVE-2026-53434?

7 open source packages ship an affected version, including org.apache.tomcat:tomcat-util and tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat-util` | Maven | From 10.1.0-M7 | 10.1.56 |
| `org.apache.tomcat:tomcat-util` | Maven | From 10.1.0-M7 | 10.1.56 |
| `org.apache.tomcat:tomcat-util` | Maven | From 11.0.0-M1 | 11.0.23 |
| `org.apache.tomcat:tomcat-util` | Maven | From 11.0.0-M1 | 11.0.23 |
| `org.apache.tomcat:tomcat-util` | Maven | From 9.0.83 | 9.0.119 |
| `org.apache.tomcat:tomcat-util` | Maven | From 9.0.83 | 9.0.119 |
| `tomcat` | Bitnami | All versions | 9.0.101, 10.1.37, 11.0.5 |

Products: Apache Tomcat.

## How do I fix CVE-2026-53434?

Upgrade org.apache.tomcat:tomcat-util to a fixed version for your release line: 10.1.56, 11.0.23 or 9.0.119.

## Is CVE-2026-53434 being exploited?

There is no known exploitation of CVE-2026-53434 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53434 and fix it if it is affected.

What it is: CVE-2026-53434 is a critical vulnerability in Apache Tomcat, published on 29 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53434 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat-util (Maven): affected from 10.1.0-M7; fixed in 10.1.56
- org.apache.tomcat:tomcat-util (Maven): affected from 10.1.0-M7; fixed in 10.1.56
- org.apache.tomcat:tomcat-util (Maven): affected from 11.0.0-M1; fixed in 11.0.23
- org.apache.tomcat:tomcat-util (Maven): affected from 11.0.0-M1; fixed in 11.0.23
- org.apache.tomcat:tomcat-util (Maven): affected from 9.0.83; fixed in 9.0.119
- org.apache.tomcat:tomcat-util (Maven): affected from 9.0.83; fixed in 9.0.119
- tomcat (Bitnami): affected all versions; fixed in 9.0.101, 10.1.37, 11.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53434/ (Markdown: https://insights.sbomify.com/CVE-2026-53434/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53434
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53434
- OSV: https://osv.dev/vulnerability/CVE-2026-53434

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53434/
Summaries are generated and may contain mistakes; the official description above is the record.
