# CVE-2026-53435: Jenkins arbitrary type deserialization from attacker-controlled config.xml allows remote code execution and user impersonation

> Attackers can deserialize arbitrary types via config.xml to impersonate users, execute code, or read files on the Jenkins controller.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 9 Sep 2026
- **Also known as:** BIT-jenkins-2026-53435, GHSA-g2xq-2v27-4rh3, MINI-5wfq-87mx-3vqx, MINI-6hj5-wf3w-47pw, MINI-jwg4-534j-7jj6, MINI-mjqf-9cjc-73hq, MINI-vv8m-87r3-w2pj, MINI-w45j-6w9g-f23g, MINI-xvvv-2r2q-388x

## What is CVE-2026-53435?

CVE-2026-53435 is a high-severity unsafe deserialization vulnerability in Jenkins Jenkins, published on 10 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Jenkins 2.567 and earlier, LTS 2.555.2 and earlier, it is possible for attackers to have Jenkins deserialize arbitrary types defined in Jenkins core or plugins from an attacker-controlled `config.xml` submission in a way that allows them to handle HTTP requests afterwards.
This can be used to impersonate any user and send HTTP requests on their behalf, up to and including use of the Script Console to run arbitrary code, or to read arbitrary files from the Jenkins controller.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-53435?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.555.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.555.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.556 | 2.568 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.556 | 2.568 |
| `jenkins` | Bitnami | All versions | 2.555.3, 2.568.0 |

Products: Jenkins Jenkins.

## How do I fix CVE-2026-53435?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.555.3 or 2.568.

## Is CVE-2026-53435 being exploited?

There is no known exploitation of CVE-2026-53435 in the wild and no public exploit code.

Public exploit code:

- An offensive security researcher + an AI vs. a fresh n-day: building the first public PoC for CVE-2026-53435 in one Friday night. Raw 8h20m log inside. (github_poc): https://github.com/AmesianX/CVE-2026-53435

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53435 and fix it if it is affected.

What it is: CVE-2026-53435 is a high-severity unsafe deserialization vulnerability in Jenkins Jenkins, published on 10 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53435 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.555.3
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.555.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.556; fixed in 2.568
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.556; fixed in 2.568
- jenkins (Bitnami): affected all versions; fixed in 2.555.3, 2.568.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53435/ (Markdown: https://insights.sbomify.com/CVE-2026-53435/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53435
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53435
- OSV: https://osv.dev/vulnerability/CVE-2026-53435

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53435/
Summaries are generated and may contain mistakes; the official description above is the record.
