# CVE-2026-53436: Jenkins Open Redirect via Relative Path Segments in Post-Login Redirect URL

> Attackers can exploit improper redirect validation to perform phishing attacks against Jenkins users.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 10 Jun 2026
- **Also known as:** BIT-jenkins-2026-53436, GHSA-3rqh-hch3-jhpc, MINI-2qh3-h4f8-49q9, MINI-4xg5-g9mw-jmrw, MINI-7g78-8j2h-c2gv, MINI-868r-mf3g-vxr8, MINI-q2jx-5vmc-6p8v, MINI-r762-fq7g-rqvf, MINI-vv9q-8cf6-c443

## What is CVE-2026-53436?

CVE-2026-53436 is a medium-severity vulnerability in Jenkins Jenkins, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins 2.567 and earlier, LTS 2.555.2 and earlier improperly determines that a redirect URL after login is legitimately pointing to Jenkins when it contains relative path segments (`./` or `../`), allowing attackers to perform phishing attacks.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-53436?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.555.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.555.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.556 | 2.568 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.556 | 2.568 |
| `jenkins` | Bitnami | All versions | 2.555.3, 2.568.0 |

Products: Jenkins Jenkins.

## How do I fix CVE-2026-53436?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.555.3 or 2.568.

## Is CVE-2026-53436 being exploited?

There is no known exploitation of CVE-2026-53436 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53436 and fix it if it is affected.

What it is: CVE-2026-53436 is a medium-severity vulnerability in Jenkins Jenkins, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-53436 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.555.3
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.555.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.556; fixed in 2.568
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.556; fixed in 2.568
- jenkins (Bitnami): affected all versions; fixed in 2.555.3, 2.568.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53436/ (Markdown: https://insights.sbomify.com/CVE-2026-53436/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53436
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53436
- OSV: https://osv.dev/vulnerability/CVE-2026-53436

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53436/
Summaries are generated and may contain mistakes; the official description above is the record.
