# CVE-2026-53440: Jenkins: Open Redirect phishing attacks possible via "from" parameter in "Delegate to servlet container"

> Attackers can redirect users to malicious domains after login in Jenkins, facilitating phishing attacks when the delegate security realm is used.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 10 Jun 2026
- **Also known as:** BIT-jenkins-2026-53440, GHSA-92m7-4fpw-2wxm, MINI-54wg-42hp-2r68, MINI-86fc-pgm3-f88w, MINI-c4wv-99vp-52qf, MINI-cq6g-3f47-q9p7, MINI-gfpc-jg8w-w6v6, MINI-j9w7-wjw4-j5rx, MINI-qx7v-hfvf-m234

## What is CVE-2026-53440?

CVE-2026-53440 is a medium-severity vulnerability in Jenkins Jenkins, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins 2.567 and earlier, LTS 2.555.2 and earlier does not ensure that the "from" parameter in the "Delegate to servlet container" security realm is safe to redirect to after login, allowing attackers to perform phishing attacks by redirecting users to an attacker-controlled domain.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-53440?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.555.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.555.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.556 | 2.568 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.556 | 2.568 |
| `jenkins` | Bitnami | All versions | 2.555.3, 2.568.0 |

Products: Jenkins Jenkins.

## How do I fix CVE-2026-53440?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.555.3 or 2.568.

## Is CVE-2026-53440 being exploited?

There is no known exploitation of CVE-2026-53440 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53440 and fix it if it is affected.

What it is: CVE-2026-53440 is a medium-severity vulnerability in Jenkins Jenkins, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-53440 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.555.3
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.555.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.556; fixed in 2.568
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.556; fixed in 2.568
- jenkins (Bitnami): affected all versions; fixed in 2.555.3, 2.568.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53440/ (Markdown: https://insights.sbomify.com/CVE-2026-53440/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53440
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53440
- OSV: https://osv.dev/vulnerability/CVE-2026-53440

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53440/
Summaries are generated and may contain mistakes; the official description above is the record.
