# CVE-2026-53441: Jenkins: Stored XSS vulnerability in node offline cause description

> Stored XSS in Jenkins allows attackers with Agent/Configure permission to execute scripts via unescaped offline cause descriptions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 6 Jul 2026
- **Also known as:** BIT-jenkins-2026-53441, GHSA-93qh-vwrm-c5pw, MINI-584x-f66p-4hh7, MINI-7mmj-hm63-42xq, MINI-84pf-v7wv-7xr8, MINI-97qf-89fg-r8f3, MINI-9fc2-7hj9-vvhm, MINI-mc8r-pf69-4j3c, MINI-xqwf-qfhr-r9qx

## What is CVE-2026-53441?

CVE-2026-53441 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 10 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins 2.483 through 2.567 (both inclusive), LTS 2.492.1 through 2.555.2 (both inclusive) does not escape the user-provided description of a generic offline cause that could be set through the `POST config.xml` API, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Agent/Configure permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-53441?

3 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.483 | 2.568 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.483 | 2.568 |
| `jenkins` | Bitnami | From 2.483.0 | 2.555.3, 2.568.0 |

Products: Jenkins Jenkins.

## How do I fix CVE-2026-53441?

Upgrade org.jenkins-ci.main:jenkins-core to 2.568 or later.

## Is CVE-2026-53441 being exploited?

There is no known exploitation of CVE-2026-53441 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53441 and fix it if it is affected.

What it is: CVE-2026-53441 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 10 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53441 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.483; fixed in 2.568
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.483; fixed in 2.568
- jenkins (Bitnami): affected from 2.483.0; fixed in 2.555.3, 2.568.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53441/ (Markdown: https://insights.sbomify.com/CVE-2026-53441/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53441
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53441
- OSV: https://osv.dev/vulnerability/CVE-2026-53441

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53441/
Summaries are generated and may contain mistakes; the official description above is the record.
