# CVE-2026-53442: Jenkins does not encrypt secrets from POST config.xml submissions before storing them in job configurations

> Attackers with Extended Read permission or file system access can view unencrypted secrets stored in Jenkins job configurations.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 10 Jun 2026
- **Also known as:** BIT-jenkins-2026-53442, GHSA-m6wv-wh8g-64xc, MINI-746j-wpxj-r84x, MINI-8vqp-gff7-cm2f, MINI-9rjw-pfqv-23wr, MINI-c9c2-qfvm-2f88, MINI-fccm-7pmf-5x9x, MINI-rc43-jg5m-r99v, MINI-wvq2-8q55-459w

## What is CVE-2026-53442?

CVE-2026-53442 is a medium-severity vulnerability in Jenkins Jenkins, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins 2.567 and earlier, LTS 2.555.2 and earlier does not encrypt secrets from POST config.xml submissions before storing them in job configurations unencrypted in job config.xml files on the Jenkins controller where they can be viewed by users with Item/Extended Read permission, or access to the Jenkins controller file system.

Weakness: CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2026-53442?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.555.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.555.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.556 | 2.568 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.556 | 2.568 |
| `jenkins` | Bitnami | All versions | 2.555.3, 2.568.0 |

Products: Jenkins Jenkins.

## How do I fix CVE-2026-53442?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.555.3 or 2.568.

## Is CVE-2026-53442 being exploited?

There is no known exploitation of CVE-2026-53442 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53442 and fix it if it is affected.

What it is: CVE-2026-53442 is a medium-severity vulnerability in Jenkins Jenkins, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53442 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.555.3
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.555.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.556; fixed in 2.568
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.556; fixed in 2.568
- jenkins (Bitnami): affected all versions; fixed in 2.555.3, 2.568.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53442/ (Markdown: https://insights.sbomify.com/CVE-2026-53442/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53442
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53442
- OSV: https://osv.dev/vulnerability/CVE-2026-53442

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53442/
Summaries are generated and may contain mistakes; the official description above is the record.
