# CVE-2026-53464: ImageMagick: Memory Leak in wand option parser when providing invalid arguments

> Attackers can cause a memory leak in ImageMagick by providing invalid arguments to the wand option parser, potentially leading to resource exhaustion.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-53464, ECHO-9147-54ce-f6c9, GHSA-j989-f892-2335, JLSEC-2026-1032, MINI-gwhp-q94m-cqj3, UBUNTU-CVE-2026-53464

## What is CVE-2026-53464?

CVE-2026-53464 is a medium-severity denial of service vulnerability in Imagemagick Imagemagick, published on 10 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to version 7.1.2-25, when providing invalid options to the wand option parser a small memory leak will occur. This issue has been patched in version 7.1.2-25.

Weakness: CWE-401 (Missing Release of Memory after Effective Lifetime)

## Which versions are affected by CVE-2026-53464?

34 open source packages ship an affected version, including Magick.NET-Q16-AnyCPU, Magick.NET-Q16-HDRI-AnyCPU and Magick.NET-Q16-HDRI-OpenMP-arm64. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-x64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-x64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q8-OpenMP-x64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q8-OpenMP-x64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q8-x64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q8-x64` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.14.0 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.14.0 |

Products: Imagemagick Imagemagick.

## How do I fix CVE-2026-53464?

Upgrade Magick.NET-Q16-AnyCPU to 14.14.0 or later.

## Is CVE-2026-53464 being exploited?

There is no known exploitation of CVE-2026-53464 in the wild and no public exploit code.

## Other vulnerabilities in Imagemagick Imagemagick

- [CVE-2019-19952](https://insights.sbomify.com/CVE-2019-19952/): Use after free in n/a (critical 9.8)
- [CVE-2018-16328](https://insights.sbomify.com/CVE-2018-16328/): Null dereference in n/a (critical 9.8)
- [CVE-2018-16329](https://insights.sbomify.com/CVE-2018-16329/): Null dereference in n/a (critical 9.8)
- [CVE-2017-18210](https://insights.sbomify.com/CVE-2017-18210/): Null dereference in n/a (critical 9.8)
- [CVE-2017-14138](https://insights.sbomify.com/CVE-2017-14138/): Denial of service in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53464 and fix it if it is affected.

What it is: CVE-2026-53464 is a medium-severity denial of service vulnerability in Imagemagick Imagemagick, published on 10 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53464 in the wild and no public exploit code.

Affected packages and fixed versions:
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.14.0
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.14.0
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.14.0
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.14.0
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.14.0
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.14.0
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.14.0
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.14.0
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.14.0
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.14.0
- Magick.NET-Q16-HDRI-x86 (NuGet): affected all versions; fixed in 14.14.0
- Magick.NET-Q16-HDRI-x86 (NuGet): affected all versions; fixed in 14.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53464/ (Markdown: https://insights.sbomify.com/CVE-2026-53464/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53464
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53464
- OSV: https://osv.dev/vulnerability/CVE-2026-53464

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53464/
Summaries are generated and may contain mistakes; the official description above is the record.
