# CVE-2026-53487: Kite has an authenticated cluster RBAC bypass in /api/v1/overview

> Authenticated users can bypass RBAC to view unauthorized cluster inventory and capacity data via the overview API endpoint.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-gvhc-wv3v-7pf8, GO-2026-5941

## What is CVE-2026-53487?

CVE-2026-53487 is a medium-severity missing authorization vulnerability in kite-org kite, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kite is a Kubernetes dashboard. Prior to version 0.12.3, authenticated Kite users with any role can request `/api/v1/overview` for a cluster that their roles do not permit by selecting that cluster with `x-cluster-name`. The overview route is registered before `middleware.RBACMiddleware()` and `GetOverview` only checks `len(user.Roles) > 0`, so it returns aggregate Kubernetes inventory and capacity data from unauthorized clusters. Version 0.12.3 fixes the issue.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-53487?

3 open source packages ship an affected version, including github.com/zxh326/kite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/zxh326/kite` | Go | All versions | 0.12.3 |
| `github.com/zxh326/kite` | Go | All versions | 0.12.3 |
| `github.com/zxh326/kite` | Go | All versions | 0.12.3 |

## How do I fix CVE-2026-53487?

Upgrade github.com/zxh326/kite to 0.12.3 or later.

## Is CVE-2026-53487 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53487 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53487 and fix it if it is affected.

What it is: CVE-2026-53487 is a medium-severity missing authorization vulnerability in kite-org kite, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53487 exists.

Affected packages and fixed versions:
- github.com/zxh326/kite (Go): affected all versions; fixed in 0.12.3
- github.com/zxh326/kite (Go): affected all versions; fixed in 0.12.3
- github.com/zxh326/kite (Go): affected all versions; fixed in 0.12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53487/ (Markdown: https://insights.sbomify.com/CVE-2026-53487/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53487
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53487
- OSV: https://osv.dev/vulnerability/CVE-2026-53487

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53487/
Summaries are generated and may contain mistakes; the official description above is the record.
