CVE-2026-53492 containerd CRI checkpoint restore CDI annotation smuggling

High 8.4 Published Updated

Attackers with pod creation permissions can bypass device plugin enforcement and inject arbitrary host mounts by smuggling CDI annotations during container checkpoint restoration.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-53492?

CVE-2026-53492 is a high-severity missing authorization vulnerability in containerd, published on 1 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

containerd is an open-source container runtime. In Versions prior to 2.3.2, 2.2.5 and 2.1.9, the CRI implementation improperly trusts Container Device Interface (CDI) annotations found within untrusted checkpoint image metadata during container restoration. When restoring a container from a checkpoint, containerd preserves CDI-related annotations from the checkpoint archive rather than relying solely on the pod's create-time specification. This allows a user with pod creation permissions to bypass standard Kubernetes resource allocation and device plugin enforcement, injecting arbitrary CDI edits (such as device nodes and host mounts) into the restored container. Successful exploitation requires that the node has CDI enabled and contains a matching host CDI specification for the requested device; environments where CDI is disabled or lacking sensitive device specifications are not affected. This issue has been fixed in versions 2.3.2, 2.2.5 and 2.1.9.

Weakness: CWE-863, CWE-20

Which versions are affected by CVE-2026-53492?

8 open source packages ship an affected version, including github.com/containerd/containerd/v2 and github.com/containerd/containerd. It affects 1 product.

PackageAffectedFixed in
github.com/containerd/containerd/v2 GoFrom 2.1.02.1.9, 2.2.5, 2.3.2
github.com/containerd/containerd/v2 GoFrom 2.1.02.1.9
github.com/containerd/containerd/v2 GoFrom 2.1.02.1.9
github.com/containerd/containerd/v2 GoFrom 2.2.02.2.5
github.com/containerd/containerd/v2 GoFrom 2.2.02.2.5
github.com/containerd/containerd/v2 GoFrom 2.3.02.3.2
2 more packages
github.com/containerd/containerd/v2 GoFrom 2.3.02.3.2
github.com/containerd/containerd GoAll versionsNone

Products include Linuxfoundation Containerd.

How do I fix CVE-2026-53492?

Upgrade github.com/containerd/containerd/v2 to a fixed version for your release line: 2.1.9, 2.2.5 or 2.3.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-53492 being exploited?

There is no known exploitation of CVE-2026-53492 in the wild and no public exploit code.

Sources

Also known as AZL-90170, BELL-CVE-2026-53492, CLEANSTART-2026-DX29618, CLEANSTART-2026-SP23014, CLEANSTART-2026-VP76604, DEBIAN-CVE-2026-53492 and 265 more.

Is CVE-2026-53492 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free