CVE-2026-53493 Containerd has image-pull DoS via crafted OCI index graph amplification
Attackers can cause denial of service in containerd by crafting OCI index graphs that trigger excessive resource consumption during image pulls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-53493?
CVE-2026-53493 is a medium-severity denial of service vulnerability in containerd, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
containerd is an open-source container runtime. Prior to versions 1.7.36, 2.0.13, 2.2.9, 2.3.6, and 2.4.1, a crafted OCI index graph can force very high CPU/memory usage during PullImage (before container start), causing long ContainerCreating stalls and, at larger sizes, node/runtime instability. Versions 1.7.36, 2.0.13, 2.2.9, 2.3.6, and 2.4.1 fix the issue.
Which versions are affected by CVE-2026-53493?
12 open source packages ship an affected version, including github.com/containerd/containerd/v2 and github.com/containerd/containerd.
| Package | Affected | Fixed in |
|---|---|---|
github.com/containerd/containerd/v2 Go | From 2.0.0 | 2.0.13, 2.2.9, 2.3.6, 2.4.1 |
github.com/containerd/containerd/v2 Go | From 2.0.0 | 2.0.13 |
github.com/containerd/containerd/v2 Go | From 2.0.0 | 2.0.13 |
github.com/containerd/containerd/v2 Go | From 2.1.0 | 2.2.9 |
github.com/containerd/containerd/v2 Go | From 2.1.0 | 2.2.9 |
github.com/containerd/containerd/v2 Go | From 2.3.0 | 2.3.6 |
6 more packages
github.com/containerd/containerd/v2 Go | From 2.3.0 | 2.3.6 |
github.com/containerd/containerd/v2 Go | From 2.4.0 | 2.4.1 |
github.com/containerd/containerd/v2 Go | From 2.4.0 | 2.4.1 |
github.com/containerd/containerd Go | All versions | 1.7.36 |
github.com/containerd/containerd Go | All versions | 1.7.36 |
github.com/containerd/containerd Go | All versions | 1.7.36 |
Linux distribution packages (1)
elemental openSUSE:Tumbleweed | All versions | 3.0.4-1.1 |
How do I fix CVE-2026-53493?
Upgrade github.com/containerd/containerd/v2 to a fixed version for your release line: 2.0.13, 2.2.9, 2.3.6 or 2.4.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-53493 being exploited?
There is no known exploitation of CVE-2026-53493 in the wild and no public exploit code.
Sources
Also known as AZL-104081, AZL-105123, BELL-CVE-2026-53493, CLEANSTART-2026-II66740, CLEANSTART-2026-LO42693, DEBIAN-CVE-2026-53493 and 430 more.