CVE-2026-53495 containerd CRI ExecSync Goroutine Leak Leading to Node-Level Denial of Service
Attackers can cause node-level denial of service in containerd by triggering goroutine leaks via CRI ExecSync, requiring an upgrade to fixed versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-53495?
CVE-2026-53495 is a medium-severity denial of service vulnerability in containerd, published on 14 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
containerd is an open-source container runtime. Prior to 1.7.35, 2.0.12, 2.2.8, and 2.3.5, containerd on Linux with the CRI plugin enabled can indefinitely block the drainExecSyncIO goroutine in internal/cri/server/container_execsync.go when CRI ExecSync is used by exec probes or lifecycle hooks that launch long-lived background child processes retaining standard input and output pipes. The input and output drain phase has no default timeout and did not stop when the request context was canceled, so repeated ExecSync invocations can accumulate blocked goroutines and host memory. The resulting resource exhaustion can cause the OOM killer to terminate containerd, leaving the container runtime unavailable until restart. Deployments not using containerd's CRI implementation and containers not running on Linux are not affected. This issue is fixed in versions 1.7.35, 2.0.12, 2.2.8, and 2.3.5.
Weakness: CWE-400
Which versions are affected by CVE-2026-53495?
10 open source packages ship an affected version, including github.com/containerd/containerd/v2 and github.com/containerd/containerd.
| Package | Affected | Fixed in |
|---|---|---|
github.com/containerd/containerd/v2 Go | All versions | 2.0.12, 2.2.8, 2.3.5 |
github.com/containerd/containerd/v2 Go | All versions | 2.0.12 |
github.com/containerd/containerd/v2 Go | All versions | 2.0.12 |
github.com/containerd/containerd/v2 Go | From 2.2.0 | 2.2.8 |
github.com/containerd/containerd/v2 Go | From 2.2.0 | 2.2.8 |
github.com/containerd/containerd/v2 Go | From 2.3.0 | 2.3.5 |
4 more packages
github.com/containerd/containerd/v2 Go | From 2.3.0 | 2.3.5 |
github.com/containerd/containerd Go | All versions | 1.7.35 |
github.com/containerd/containerd Go | All versions | 1.7.35 |
github.com/containerd/containerd Go | All versions | 1.7.35 |
Linux distribution packages (2)
hauler openSUSE:Tumbleweed | All versions | 2.1.0-4.1 |
trivy openSUSE:Tumbleweed | All versions | 0.75.0-1.1 |
How do I fix CVE-2026-53495?
Upgrade github.com/containerd/containerd/v2 to a fixed version for your release line: 2.0.12, 2.2.8 or 2.3.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-53495 being exploited?
There is no known exploitation of CVE-2026-53495 in the wild and no public exploit code.
Sources
Also known as AZL-100986, AZL-101004, BELL-CVE-2026-53495, CLEANSTART-2026-HA58928, CLEANSTART-2026-MU77923, CLEANSTART-2026-NV54343 and 303 more.