# CVE-2026-53496: ExifReader HEIC/AVIF ISO-BMFF parser throws uncaught RangeError on truncated boxes

> Attackers can cause denial of service in applications using ExifReader by supplying malformed HEIC or AVIF images that trigger uncaught errors.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-g77h-45rf-hcx4

## What is CVE-2026-53496?

CVE-2026-53496 is a medium-severity denial of service vulnerability in mattiasw ExifReader, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ExifReader is a JavaScript Exif information parser. Prior to 4.40.1, ExifReader.load() and the asynchronous file and URL loaders can pass attacker-supplied HEIC or AVIF data to the ISO-BMFF parser in src/image-header-iso-bmff.js, where findMetaBox() and parseBox() accept an eight-byte box header without confirming that fields required by the parsed box remain in the DataView. A valid ftyp box followed by an empty free or unknown box can cause an unchecked full-box version read, while a truncated extended-size box can make getBoxLength() and hasEmptyHighBits() read absent size fields. The resulting RangeError escapes the main parsing path and can abort an application request or worker when parse errors are not defensively caught, causing denial of service. This issue is fixed in version 4.40.1.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions), CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-53496?

2 open source packages ship an affected version, including exifreader.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `exifreader` | npm | All versions | 4.40.1 |
| `exifreader` | npm | All versions | 4.40.1 |

## How do I fix CVE-2026-53496?

Upgrade exifreader to 4.40.1 or later.

## Is CVE-2026-53496 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53496 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53496 and fix it if it is affected.

What it is: CVE-2026-53496 is a medium-severity denial of service vulnerability in mattiasw ExifReader, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53496 exists.

Affected packages and fixed versions:
- exifreader (npm): affected all versions; fixed in 4.40.1
- exifreader (npm): affected all versions; fixed in 4.40.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53496/ (Markdown: https://insights.sbomify.com/CVE-2026-53496/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53496
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53496
- OSV: https://osv.dev/vulnerability/CVE-2026-53496

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53496/
Summaries are generated and may contain mistakes; the official description above is the record.
