# CVE-2026-53510: Savon::Model evaluates WSDL operation names as Ruby source

> Attackers can execute arbitrary Ruby code by providing malicious WSDL operation names to the Savon SOAP client library.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-mx5j-mp4f-g8jg

## What is CVE-2026-53510?

CVE-2026-53510 is a high-severity code injection vulnerability in savonrb savon, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Savon is a Ruby SOAP client. From 0.9.8 until 2.17.2, Savon::Model .all_operations interpolates attacker-controlled WSDL operation names into Ruby source passed to module_eval, allowing Ruby code execution in the application process. This issue is fixed in version 2.17.2.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-53510?

2 open source packages ship an affected version, including savon.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `savon` | RubyGems | From 0.9.8 | 2.17.2 |
| `savon` | RubyGems | From 0.9.8 | 2.17.2 |

## How do I fix CVE-2026-53510?

Upgrade savon to 2.17.2 or later.

## Is CVE-2026-53510 being exploited?

There is no known exploitation of CVE-2026-53510 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53510 and fix it if it is affected.

What it is: CVE-2026-53510 is a high-severity code injection vulnerability in savonrb savon, published on 31 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53510 in the wild and no public exploit code.

Affected packages and fixed versions:
- savon (RubyGems): affected from 0.9.8; fixed in 2.17.2
- savon (RubyGems): affected from 0.9.8; fixed in 2.17.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53510/ (Markdown: https://insights.sbomify.com/CVE-2026-53510/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53510
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53510
- OSV: https://osv.dev/vulnerability/CVE-2026-53510

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53510/
Summaries are generated and may contain mistakes; the official description above is the record.
