# CVE-2026-53511: calibre: Arbitrary Code Execution in Template Formatter via Book Metadata

> Attackers can execute arbitrary Python code by tricking users into opening malicious e-book files with crafted metadata in calibre.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 18 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-53511, GHSA-2j4m-2q7x-2c47, UBUNTU-CVE-2026-53511, openSUSE-SU-2026:11130-1

## What is CVE-2026-53511?

CVE-2026-53511 is a high-severity code injection vulnerability in kovidgoyal calibre, published on 7 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

calibre is an e-book manager. Prior to 9.10.0, a malicious EPUB, OPF, or PDF file can execute arbitrary Python code when its metadata is read by calibre, including through Add books or Edit books, by embedding a custom column definition with a python: template in calibre:user_metadata that is passed unsanitized to exec() in the template formatter. This issue is fixed in version 9.10.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-53511?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `calibre` | openSUSE:Tumbleweed | All versions | 9.10.0-1.1 |

## How do I fix CVE-2026-53511?

Upgrade to a fixed version.

## Is CVE-2026-53511 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53511 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53511 and fix it if it is affected.

What it is: CVE-2026-53511 is a high-severity code injection vulnerability in kovidgoyal calibre, published on 7 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53511 exists.

Affected product: kovidgoyal calibre. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53511/ (Markdown: https://insights.sbomify.com/CVE-2026-53511/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53511
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53511
- OSV: https://osv.dev/vulnerability/CVE-2026-53511

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53511/
Summaries are generated and may contain mistakes; the official description above is the record.
