# CVE-2026-53512: Better Auth: OAuth refresh-token replay via missing client authentication on oidc-provider and mcp plugins

> Attackers can replay OAuth refresh tokens to mint access tokens because the oidc-provider and mcp plugins fail to verify client secrets.

- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 18 Jul 2026
- **Also known as:** GHSA-pw9m-5jxm-xr6h

## What is CVE-2026-53512?

CVE-2026-53512 is a critical authentication bypass vulnerability in better-auth, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Better Auth is an authentication and authorization library for TypeScript. Prior to 1.6.11, the legacy oidcProvider and mcp plugins expose OAuth token endpoints whose refresh_token grant authenticates only possession of the bound refreshToken row and matching client_id, without verifying the confidential client's client_secret, allowing an attacker with a valid refresh_token to mint access tokens and rotated refresh tokens through /api/auth/oauth2/token or /api/auth/mcp/token. The @better-auth/oauth-provider package is not affected. This issue is fixed in version 1.6.11.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-863 (Incorrect Authorization), CWE-306 (Missing Authentication for Critical Functionality), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-53512?

2 open source packages ship an affected version, including better-auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | All versions | 1.6.11 |
| `better-auth` | npm | All versions | 1.6.11 |

Products: Better-Auth Better Auth.

## How do I fix CVE-2026-53512?

Upgrade better-auth to 1.6.11 or later.

## Is CVE-2026-53512 being exploited?

There is no known exploitation of CVE-2026-53512 in the wild and no public exploit code.

## Other vulnerabilities in better-auth

- [CVE-2026-53516](https://insights.sbomify.com/CVE-2026-53516/): Better Auth: Account takeover via OAuth auto-link to unverified pre-registered email (high 8.3)
- [CVE-2024-56734](https://insights.sbomify.com/CVE-2024-56734/): Better Auth has an Open Redirect Vulnerability in Verify Email Endpoint (high 7.9)
- [CVE-2026-53514](https://insights.sbomify.com/CVE-2026-53514/): Better Auth: Unauthorized invitation acceptance via unverified email match in organization plugin (high 7.7)
- [CVE-2026-45337](https://insights.sbomify.com/CVE-2026-45337/): Better Auth: Device authorization approve and deny accept any authenticated session while the user code is pending (high 7.6)
- [CVE-2025-27143](https://insights.sbomify.com/CVE-2025-27143/): Beter Auth has an Open Redirect via Scheme-Less Callback Parameter (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53512 and fix it if it is affected.

What it is: CVE-2026-53512 is a critical authentication bypass vulnerability in better-auth, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53512 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected all versions; fixed in 1.6.11
- better-auth (npm): affected all versions; fixed in 1.6.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53512/ (Markdown: https://insights.sbomify.com/CVE-2026-53512/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53512
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53512
- OSV: https://osv.dev/vulnerability/CVE-2026-53512

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53512/
Summaries are generated and may contain mistakes; the official description above is the record.
