# CVE-2026-53514: Better Auth: Unauthorized invitation acceptance via unverified email match in organization plugin

> Attackers can accept organization invitations without verified email ownership if specific configuration options are disabled, leading to unauthorized access.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 18 Jul 2026
- **Also known as:** GHSA-fmh4-wcc4-5jm3

## What is CVE-2026-53514?

CVE-2026-53514 is a high-severity missing authorization vulnerability in better-auth, published on 15 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Better Auth is an authentication and authorization library for TypeScript. Prior to 1.6.11, and in 1.6.14 and later when invitation IDs can be obtained outside the invited mailbox and requireEmailVerificationOnInvitation: true is not enabled, the organization plugin's acceptInvitation, rejectInvitation, getInvitation, and listUserInvitations recipient endpoints use session.user.email and an invitation ID without sufficient verified-email ownership proof, allowing a user with an unverified session for the invited email address to accept an organization invitation after obtaining the invitation ID. This issue is fixed for the original default behavior in version 1.6.11, while 1.6.14 restored compatibility for built-in opaque invitation IDs and leaves affected configurations requiring secure options.

Weakness: CWE-862 (Missing Authorization), CWE-441 (Unintended Proxy or Intermediary), CWE-345 (Insufficient Verification of Data Authenticity), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-53514?

2 open source packages ship an affected version, including better-auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | All versions | 1.6.11 |
| `better-auth` | npm | All versions | 1.6.11 |

Products: Better-Auth Better Auth.

## How do I fix CVE-2026-53514?

Upgrade better-auth to 1.6.11 or later.

## Is CVE-2026-53514 being exploited?

There is no known exploitation of CVE-2026-53514 in the wild and no public exploit code.

## Other vulnerabilities in better-auth

- [CVE-2026-53512](https://insights.sbomify.com/CVE-2026-53512/): Better Auth: OAuth refresh-token replay via missing client authentication on oidc-provider and mcp plugins (critical 9.1)
- [CVE-2026-53516](https://insights.sbomify.com/CVE-2026-53516/): Better Auth: Account takeover via OAuth auto-link to unverified pre-registered email (high 8.3)
- [CVE-2024-56734](https://insights.sbomify.com/CVE-2024-56734/): Better Auth has an Open Redirect Vulnerability in Verify Email Endpoint (high 7.9)
- [CVE-2026-45337](https://insights.sbomify.com/CVE-2026-45337/): Better Auth: Device authorization approve and deny accept any authenticated session while the user code is pending (high 7.6)
- [CVE-2025-27143](https://insights.sbomify.com/CVE-2025-27143/): Beter Auth has an Open Redirect via Scheme-Less Callback Parameter (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53514 and fix it if it is affected.

What it is: CVE-2026-53514 is a high-severity missing authorization vulnerability in better-auth, published on 15 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-53514 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected all versions; fixed in 1.6.11
- better-auth (npm): affected all versions; fixed in 1.6.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53514/ (Markdown: https://insights.sbomify.com/CVE-2026-53514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53514
- OSV: https://osv.dev/vulnerability/CVE-2026-53514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53514/
Summaries are generated and may contain mistakes; the official description above is the record.
