CVE-2026-53527 LeafWiki Vulnerable to Privilege Escalation via User Self-Service Update
Authenticated users can escalate privileges to admin by modifying their own role via the user update API in LeafWiki.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-53527?
CVE-2026-53527 is a high-severity vulnerability in perber leafwiki, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
LeafWiki is a self-hosted wiki. Versions 0.1.0 through 0.10.0 have a privilege escalation vulnerability in the user update API. An authenticated user could update their own account role and escalate privileges from a regular user, such as `viewer`, to `admin`. Exploitation requires a valid authenticated LeafWiki user account. Instances without public registration and with only trusted users are at lower practical risk. Users should update to version 0.10.1 or greater. Until a patch is available, operators should restrict account creation and ensure that only trusted users have accounts on affected LeafWiki instances. If possible, access to the user update API should be restricted to trusted users or administrators only.
Weakness: CWE-269
Which versions are affected by CVE-2026-53527?
How do I fix CVE-2026-53527?
No fix has been published for CVE-2026-53527 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-53527 being exploited?
There is no known exploitation of CVE-2026-53527 in the wild and no public exploit code.
Sources
Also known as GHSA-jj4r-587p-r5h5.