# CVE-2026-53527: LeafWiki Vulnerable to Privilege Escalation via User Self-Service Update

> Authenticated users can escalate privileges to admin by modifying their own role via the user update API in LeafWiki.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Aug 2026
- **Updated:** 24 Aug 2026
- **Also known as:** GHSA-jj4r-587p-r5h5

## What is CVE-2026-53527?

CVE-2026-53527 is a high-severity vulnerability in perber leafwiki, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LeafWiki is a self-hosted wiki. Versions 0.1.0 through 0.10.0 have a privilege escalation vulnerability in the user update API. An authenticated user could update their own account role and escalate privileges from a regular user, such as `viewer`, to `admin`. Exploitation requires a valid authenticated LeafWiki user account. Instances without public registration and with only trusted users are at lower practical risk. Users should update to version 0.10.1 or greater. Until a patch is available, operators should restrict account creation and ensure that only trusted users have accounts on affected LeafWiki instances. If possible, access to the user update API should be restricted to trusted users or administrators only.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-53527?


## How do I fix CVE-2026-53527?

No fix has been published for CVE-2026-53527 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-53527 being exploited?

There is no known exploitation of CVE-2026-53527 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53527 and fix it if it is affected.

What it is: CVE-2026-53527 is a high-severity vulnerability in perber leafwiki, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53527 in the wild and no public exploit code.

Affected product: perber leafwiki. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53527/ (Markdown: https://insights.sbomify.com/CVE-2026-53527/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53527
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53527
- OSV: https://osv.dev/vulnerability/CVE-2026-53527

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53527/
Summaries are generated and may contain mistakes; the official description above is the record.
