# CVE-2026-53528: FileWiki has path traversal in RenameAsset via unsanitized oldFilename parameter


- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** GHSA-g2wp-jm5c-jqfj

## What is CVE-2026-53528?

CVE-2026-53528 is a high-severity vulnerability in perber leafwiki, published on 21 Aug 2026. 

### Official description

LeafWiki is a self-hosted wiki. Versions 0.3.0 through 0.10.0 have a path traversal vulnerability in LeafWiki’s asset rename functionality. An authenticated user with editor permissions could move files that are accessible to the LeafWiki server process into a page’s asset directory. This could allow sensitive local files, such as the application database, to become downloadable as page assets. Users should update to version 0.10.1 or greater. As an additional mitigation, operators should ensure that the LeafWiki process runs with the least privileges necessary and does not have filesystem access to sensitive files outside the application’s required directories. Until a patch is applied, operators may reduce risk by restricting editor access to trusted users only and by limiting the filesystem permissions of the LeafWiki process.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2026-53528?


## How do I fix CVE-2026-53528?

No fix has been published for CVE-2026-53528 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-53528 being exploited?

There is no known exploitation of CVE-2026-53528 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53528 and fix it if it is affected.

What it is: CVE-2026-53528 is a high-severity vulnerability in perber leafwiki, published on 21 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2026-53528 in the wild and no public exploit code.

Affected product: perber leafwiki. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53528/ (Markdown: https://insights.sbomify.com/CVE-2026-53528/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53528
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53528
- OSV: https://osv.dev/vulnerability/CVE-2026-53528

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53528/
Summaries are generated and may contain mistakes; the official description above is the record.
