# CVE-2026-53537: Python-Multipart: Content-Disposition parameter smuggling via RFC 2231/5987 extended parameters

> Attackers can smuggle malicious filenames or field names past security filters by exploiting RFC 2231/5987 parameter decoding discrepancies in the Python-Multipart library.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** CLEANSTART-2026-HR94860, CLEANSTART-2026-JY83445, DEBIAN-CVE-2026-53537, ECHO-7b4c-b0bf-6c71, GHSA-vffw-93wf-4j4q, MINI-29w8-g8f3-gx3f, MINI-2gm9-62rv-w9mr, MINI-4f3j-3378-8pcj, MINI-4pjf-fxgq-c9fr, MINI-58x4-wxv3-2xc5, MINI-5m3q-jqrc-crhc, MINI-6g33-wr35-f9v4, MINI-97rq-f5hp-283h, MINI-fwp2-jchc-m3vq, MINI-gff4-cpfc-x497, MINI-mr7p-x84m-4vf7, MINI-prpv-4fq2-g7r7, MINI-q2w8-c579-2577, MINI-rmvf-qgh9-95x6, MINI-rpcj-pw3w-9r4r, MINI-x99p-666m-c4cw, PYSEC-2026-3041, ROOT-APP-PYPI-CVE-2026-53537, UBUNTU-CVE-2026-53537

## What is CVE-2026-53537?

CVE-2026-53537 is a low-severity vulnerability in Kludex python-multipart, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Python-Multipart is a streaming multipart parser for Python. Prior to 0.0.30, parse_options_header parsed Content-Disposition (and Content-Type) headers with email.message.Message, which transparently applies RFC 2231/5987 decoding. The extended parameter syntax (filename*=charset'lang'value, name*=..., and the filename*0/filename*1 continuation form) is decoded and surfaced under the bare filename/name key, and overrides the plain parameter when both are present. RFC 7578 §4.2 explicitly forbids the filename* form in multipart/form-data. Components that follow RFC 7578, or that do not implement RFC 2231/5987 decoding for multipart/form-data (WAFs, proxies, gateways), may interpret such a header differently. An attacker can exploit that difference to smuggle a different field name or filename past an upstream inspector to the backend. This vulnerability is fixed in 0.0.30.

Weakness: CWE-436 (Interpretation Conflict), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-53537?

3 open source packages ship an affected version, including python-multipart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-multipart` | PyPI | All versions | 0.0.30 |
| `python-multipart` | PyPI | All versions | 0.0.30 |
| `python-multipart` | PyPI | All versions | 0.0.30 |

Products: Fastapiexpert Python-Multipart.

## How do I fix CVE-2026-53537?

Upgrade python-multipart to 0.0.30 or later.

## Is CVE-2026-53537 being exploited?

There is no known exploitation of CVE-2026-53537 in the wild and no public exploit code.

## Other vulnerabilities in Kludex python-multipart

- [CVE-2026-24486](https://insights.sbomify.com/CVE-2026-24486/): Python-Multipart has Arbitrary File Write via Non-Default Configuration (high 8.6)
- [CVE-2026-53539](https://insights.sbomify.com/CVE-2026-53539/): Python-Multipart: Quadratic-time querystring parsing with semicolon separators causes CPU denial of service (high 7.5)
- [CVE-2024-24762](https://insights.sbomify.com/CVE-2024-24762/): python-multipart vulnerable to content-type header Regular expression Denial of Service (high 7.5)
- [CVE-2026-40347](https://insights.sbomify.com/CVE-2026-40347/): Python-Multipart affected by Denial of Service via large multipart preamble or epilogue data (medium 5.3)
- [CVE-2026-53538](https://insights.sbomify.com/CVE-2026-53538/): Python-Multipart: Semicolon treated as querystring field separator enables parameter smuggling (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53537 and fix it if it is affected.

What it is: CVE-2026-53537 is a low-severity vulnerability in Kludex python-multipart, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53537 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-multipart (PyPI): affected all versions; fixed in 0.0.30
- python-multipart (PyPI): affected all versions; fixed in 0.0.30
- python-multipart (PyPI): affected all versions; fixed in 0.0.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53537/ (Markdown: https://insights.sbomify.com/CVE-2026-53537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53537
- OSV: https://osv.dev/vulnerability/CVE-2026-53537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53537/
Summaries are generated and may contain mistakes; the official description above is the record.
