# CVE-2026-53538: Python-Multipart: Semicolon treated as querystring field separator enables parameter smuggling

> Attacker can smuggle form fields by exploiting parser differences in Python-Multipart, bypassing upstream security checks.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** CLEANSTART-2026-BI20445, CLEANSTART-2026-KU79465, DEBIAN-CVE-2026-53538, ECHO-1ad6-2748-b07b, GHSA-6jv3-5f52-599m, MINI-3x2w-39vg-5rp8, MINI-4qfp-xphg-jfmq, MINI-556q-337q-h6g4, MINI-5xj9-3hxh-hr3g, MINI-6v4q-q7vv-g5cc, MINI-93wv-qg5w-6844, MINI-9v2v-p536-fj4x, MINI-cmrp-g767-qrgh, MINI-cprq-pmm3-75v8, MINI-g64v-29f3-mj6x, MINI-g9cw-hm59-rfxf, MINI-hx67-xh5p-rvvx, MINI-p39p-w7rv-q4jq, MINI-rx65-3pqx-4x76, MINI-w77h-9gcg-2w49, MINI-xwp5-28jg-2p7h, PYSEC-2026-3037, ROOT-APP-PYPI-CVE-2026-53538, UBUNTU-CVE-2026-53538

## What is CVE-2026-53538?

CVE-2026-53538 is a low-severity vulnerability in Kludex python-multipart, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Python-Multipart is a streaming multipart parser for Python. Prior to 0.0.30, QuerystringParser treated ; as a field separator in application/x-www-form-urlencoded bodies, in addition to &. The WHATWG URL standard, modern browsers, and Python's urllib.parse (since the CVE-2021-23336 fix) treat only & as a separator. This creates a parser differential: the same bytes are tokenized into different fields than a WHATWG compliant intermediary would produce, allowing an attacker to smuggle extra form fields past an upstream body inspecting component. This vulnerability is fixed in 0.0.30.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests), CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-53538?

3 open source packages ship an affected version, including python-multipart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-multipart` | PyPI | All versions | 0.0.30 |
| `python-multipart` | PyPI | All versions | 0.0.30 |
| `python-multipart` | PyPI | All versions | 0.0.30 |

Products: Fastapiexpert Python-Multipart.

## How do I fix CVE-2026-53538?

Upgrade python-multipart to 0.0.30 or later.

## Is CVE-2026-53538 being exploited?

There is no known exploitation of CVE-2026-53538 in the wild and no public exploit code.

## Other vulnerabilities in Kludex python-multipart

- [CVE-2026-24486](https://insights.sbomify.com/CVE-2026-24486/): Python-Multipart has Arbitrary File Write via Non-Default Configuration (high 8.6)
- [CVE-2026-53539](https://insights.sbomify.com/CVE-2026-53539/): Python-Multipart: Quadratic-time querystring parsing with semicolon separators causes CPU denial of service (high 7.5)
- [CVE-2024-24762](https://insights.sbomify.com/CVE-2024-24762/): python-multipart vulnerable to content-type header Regular expression Denial of Service (high 7.5)
- [CVE-2026-40347](https://insights.sbomify.com/CVE-2026-40347/): Python-Multipart affected by Denial of Service via large multipart preamble or epilogue data (medium 5.3)
- [CVE-2026-53537](https://insights.sbomify.com/CVE-2026-53537/): Python-Multipart: Content-Disposition parameter smuggling via RFC 2231/5987 extended parameters (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53538 and fix it if it is affected.

What it is: CVE-2026-53538 is a low-severity vulnerability in Kludex python-multipart, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53538 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-multipart (PyPI): affected all versions; fixed in 0.0.30
- python-multipart (PyPI): affected all versions; fixed in 0.0.30
- python-multipart (PyPI): affected all versions; fixed in 0.0.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53538/ (Markdown: https://insights.sbomify.com/CVE-2026-53538/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53538
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53538
- OSV: https://osv.dev/vulnerability/CVE-2026-53538

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53538/
Summaries are generated and may contain mistakes; the official description above is the record.
