# CVE-2026-53550: js-yaml: Quadratic-complexity DoS in merge key handling via repeated aliases

> Attackers can cause denial of service in applications using js-yaml by submitting crafted YAML documents that trigger quadratic CPU exhaustion during merge key processing.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 29 Jun 2026
- **Also known as:** CLEANSTART-2026-EU49619, CLEANSTART-2026-RB45819, CLEANSTART-2026-ZI17820, CLEANSTART-2026-ZU44577, CLSA-2026-1790186133, CLSA-2026-1790944130, DEBIAN-CVE-2026-53550, ECHO-b33f-9f57-0682, GHSA-h67p-54hq-rp68, MINI-272r-8h37-wjj7, MINI-364m-8wpj-xm89, MINI-3jm7-p6c7-j6g5, MINI-59x5-v78r-qj94, MINI-62v8-6xcg-c248, MINI-752m-64qw-74c3, MINI-76ww-r3w5-fcjr, MINI-7gqw-5m4j-3q5f, MINI-7m7g-4vmf-jhmr, MINI-7qfg-7mpw-rf3v, MINI-888p-c7xg-5wx7, MINI-8qmv-8f9f-5w8v, MINI-98c9-5vmc-5w7x, MINI-9g35-c55q-6pp7, MINI-cwvj-h84q-fjv2, MINI-fr55-4vv5-vf3v, MINI-g668-4rfg-mc4h, MINI-gppc-q7x2-vvc9, MINI-gvw3-65xm-2q4v, MINI-j272-6fv2-732f, MINI-m4pr-jrc6-pwfg, MINI-mcgr-2qcc-rrw8, MINI-mqmr-vfmq-4p3j, MINI-pfxq-3xxc-fxv6, MINI-q3q6-wh6x-mgrv, MINI-q3wh-9pw7-xxhx, MINI-r58m-m9cx-c7hh, MINI-rpv5-4xpj-hqq9, MINI-v6cr-h2ch-jqrh, MINI-vm9f-pgmw-xgfg, MINI-vrfm-c2vm-jjw3, MINI-wvfh-f4p4-vr66, MINI-x3hq-j2f7-m3p5, MINI-x563-3c6v-qmf6, MINI-xxh2-jmrm-m45q, ROOT-APP-NPM-CVE-2026-53550, UBUNTU-CVE-2026-53550, openSUSE-SU-2026:11148-1

## What is CVE-2026-53550?

CVE-2026-53550 is a medium-severity denial of service vulnerability in nodeca js-yaml, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

js-yaml is a JavaScript YAML parser and dumper. Prior to 4.2.0 and 3.15.0, a crafted YAML document can trigger algorithmic CPU exhaustion in js-yaml merge-key processing (<<) by repeating the same alias many times in a merge sequence. This causes quadratic parse-time behavior relative to input size and can block a Node.js worker/event loop for seconds with a relatively small payload (tens of KB), resulting in denial of service. The issue is in merge handling inside lib/loader.js. This vulnerability is fixed in 4.2.0 and 3.15.0.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-53550?

4 open source packages ship an affected version, including js-yaml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `js-yaml` | npm | All versions | 3.15.0 |
| `js-yaml` | npm | All versions | 3.15.0 |
| `js-yaml` | npm | From 4.0.0 | 4.2.0 |
| `js-yaml` | npm | From 4.0.0 | 4.2.0 |
| `python-pydata-sphinx-theme` | openSUSE:Tumbleweed | All versions | 0.19.0-1.1 |

Products: Nodeca Js-Yaml.

## How do I fix CVE-2026-53550?

Upgrade js-yaml to a fixed version for your release line: 3.15.0 or 4.2.0.

## Is CVE-2026-53550 being exploited?

There is no known exploitation of CVE-2026-53550 in the wild and no public exploit code.

## Other vulnerabilities in nodeca js-yaml

- [CVE-2026-59869](https://insights.sbomify.com/CVE-2026-59869/): js-yaml: YAML merge-key chains can force quadratic CPU consumption (high 7.5)
- [CVE-2026-59870](https://insights.sbomify.com/CVE-2026-59870/): js-yaml quadratic-complexity denial of service via YAML11_SCHEMA !!omap parsing (high 7.5)
- [CVE-2013-4660](https://insights.sbomify.com/CVE-2013-4660/): Deserialization Code Execution in js-yaml (medium 6.8)
- [CVE-2026-59868](https://insights.sbomify.com/CVE-2026-59868/): js-yaml: YAML merge-key chains can force quadratic CPU consumption (medium 5.3)
- [CVE-2025-64718](https://insights.sbomify.com/CVE-2025-64718/): js-yaml has prototype pollution in merge (<<) (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53550 and fix it if it is affected.

What it is: CVE-2026-53550 is a medium-severity denial of service vulnerability in nodeca js-yaml, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53550 in the wild and no public exploit code.

Affected packages and fixed versions:
- js-yaml (npm): affected all versions; fixed in 3.15.0
- js-yaml (npm): affected all versions; fixed in 3.15.0
- js-yaml (npm): affected from 4.0.0; fixed in 4.2.0
- js-yaml (npm): affected from 4.0.0; fixed in 4.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53550/ (Markdown: https://insights.sbomify.com/CVE-2026-53550/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53550
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53550
- OSV: https://osv.dev/vulnerability/CVE-2026-53550

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53550/
Summaries are generated and may contain mistakes; the official description above is the record.
