# CVE-2026-53561: Auth bypass in Apache Hive

> Unauthenticated attackers can impersonate any Hive user via forged SAML tokens in HTTP mode, gaining unauthorized access to data.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** GHSA-g32f-6xhp-3ffw

## What is CVE-2026-53561?

CVE-2026-53561 is a high-severity authentication bypass vulnerability in Apache Hive, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An improper authentication vulnerability in HiveServer2 SAML bearer-token validation in Apache Hive 4.0.0 through 4.2.0 (and later unreleased branches) on deployments using HTTP transport with hive.server2.authentication=SAML allows an unauthenticated network attacker to authenticate as an arbitrary Hive user and obtain an authenticated HiveServer2 session via a forged Authorization: Bearer token sent to the /cliservice HTTP endpoint. Users are recommended to upgrade to 4.2.1 version that includes the fix for this issue.

Access / authorization required: No Hive credentials, SAML IdP login, or knowledge of the server signing secret is required. The attacker only needs network reachability to the HiveServer2 HTTP port (typically /cliservice), directly or through a reverse proxy such as Apache Knox that forwards unauthenticated requests to HS2. The instance must have SAML authentication enabled in HTTP mode. Deployments where Knox handles SSO and HiveServer2 uses LDAP/Kerberos (not native SAML mode) are not affected by this specific issue.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-305 (Authentication Bypass by Primary Weakness), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-53561?

It affects 1 product.


Products: Apache Hive.

## How do I fix CVE-2026-53561?

No fix has been published for CVE-2026-53561 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-53561 being exploited?

There is no known exploitation of CVE-2026-53561 in the wild and no public exploit code.

## Other vulnerabilities in Apache Hive

- [CVE-2026-49845](https://insights.sbomify.com/CVE-2026-49845/): Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths (critical 9.8)
- [CVE-2018-21234](https://insights.sbomify.com/CVE-2018-21234/): Deserialization of Untrusted Data in Jodd (critical 9.8)
- [CVE-2026-55976](https://insights.sbomify.com/CVE-2026-55976/): Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url (critical 9.1)
- [CVE-2018-1282](https://insights.sbomify.com/CVE-2018-1282/): SQL Injection in hive-jdbc (critical 9.1)
- [CVE-2022-41137](https://insights.sbomify.com/CVE-2022-41137/): Apache Hive: Deserialization of untrusted data when fetching partitions from the Metastore (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53561 and fix it if it is affected.

What it is: CVE-2026-53561 is a high-severity authentication bypass vulnerability in Apache Hive, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53561 in the wild and no public exploit code.

Affected product: Apache Hive. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53561/ (Markdown: https://insights.sbomify.com/CVE-2026-53561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53561
- OSV: https://osv.dev/vulnerability/CVE-2026-53561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53561/
Summaries are generated and may contain mistakes; the official description above is the record.
