# CVE-2026-53582: OPNsense: XPATH Injection can disclose any secret in config.xml

> Privileged users can exploit XPath injection in the Trust module to extract sensitive secrets like keys and credentials from the configuration file.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** GHSA-xww7-76m6-mh2r

## What is CVE-2026-53582?

CVE-2026-53582 is a high-severity vulnerability in opnsense core, published on 15 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OPNsense is a FreeBSD based firewall and routing platform. Prior to version 26.1.10, the Trust module stores attacker-controlled certificate authority and certificate refid values and interpolates them into XPath expressions in src/opnsense/mvc/app/models/OPNsense/Trust/FieldTypes/CAsField.php and src/opnsense/mvc/app/models/OPNsense/Trust/FieldTypes/CertificatesField.php. A user with CA Manager or Certificate Manager privileges can submit a crafted refid and repeatedly retrieve the object to obtain a boolean refcount oracle, allowing values in config.xml to be recovered character by character. Exposed values can include password hashes, API credentials, certificate private keys, VPN key material, and high-availability credentials, enabling privilege escalation and compromise of other security domains. This issue is fixed in version 26.1.10.

Weakness: CWE-91 (XML Injection), CWE-643 (Improper Neutralization of Data within XPath Expressions)

## Which versions are affected by CVE-2026-53582?


## How do I fix CVE-2026-53582?

No fix has been published for CVE-2026-53582 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-53582 being exploited?

There is no known exploitation of CVE-2026-53582 in the wild and no public exploit code.

Public exploit code:

- https://github.com/eev4n/CVE-2026-53582 (github_poc): https://github.com/eev4n/CVE-2026-53582

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53582 and fix it if it is affected.

What it is: CVE-2026-53582 is a high-severity vulnerability in opnsense core, published on 15 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53582 in the wild and no public exploit code.

Affected product: opnsense core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53582/ (Markdown: https://insights.sbomify.com/CVE-2026-53582/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53582
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53582
- OSV: https://osv.dev/vulnerability/CVE-2026-53582

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53582/
Summaries are generated and may contain mistakes; the official description above is the record.
