{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53583 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-53583 is a medium-severity vulnerability in libgit2, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-53583 and fix it if it is affected.\n\nWhat it is: CVE-2026-53583 is a medium-severity vulnerability in libgit2, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53583 exists.\n\nAffected product: libgit2. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53583/ (Markdown: https://insights.sbomify.com/CVE-2026-53583/index.md)","id":"CVE-2026-53583","markdown":"https://insights.sbomify.com/CVE-2026-53583/index.md","name":"CVE-2026-53583","record":{"aliases":["AZL-96971","BELL-CVE-2026-53583","DEBIAN-CVE-2026-53583","ECHO-417b-96b7-cd13","GHSA-h7gc-w2gg-p9xp","JLSEC-2026-1369","MINI-643c-c97m-wfmq","UBUNTU-CVE-2026-53583","USN-8907-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Git core library","requires_auth":"none","summary":"A logic error in libgit2's OpenSSL backend allows attackers to bypass IP-based certificate validation, enabling man-in-the-middle attacks on IP-literal HTTPS connections.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-297","name":"Improper Validation of Certificate with Host Mismatch"},{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Prior to 1.8.6 and 1.9.5, verify_server_cert in src/libgit2/streams/openssl.c uses an inverted !!memcmp result in the GEN_IPADD branch when comparing an IP-literal host with a certificate IP SubjectAltName. OpenSSL builds reject matching IP addresses and accept mismatched IP addresses, allowing a network attacker with a CA-trusted certificate containing any IP SubjectAltName to intercept libgit2 connections to IP-literal HTTPS URLs. DNS SubjectAltName validation and non-OpenSSL TLS backends are not affected. This issue is fixed in versions 1.8.6 and 1.9.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"libgit2: Inverted IP SubjectAltName Comparison in OpenSSL Backend","id":"CVE-2026-53583","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":0,"n_references":6,"next":{"headline":"libgit2: Submodule path traversal","id":"CVE-2026-53584"},"packages":[],"prev":{"headline":"OPNsense: XPATH Injection can disclose any secret in config.xml","id":"CVE-2026-53582"},"products":["libgit2"],"published":"2026-08-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-20","vendors":["libgit2"]},"summary":"A logic error in libgit2's OpenSSL backend allows attackers to bypass IP-based certificate validation, enabling man-in-the-middle attacks on IP-literal HTTPS connections.","url":"https://insights.sbomify.com/CVE-2026-53583/"}