{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53585 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-53585 is a medium-severity denial of service vulnerability in libgit2, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-53585 and fix it if it is affected.\n\nWhat it is: CVE-2026-53585 is a medium-severity denial of service vulnerability in libgit2, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53585 exists.\n\nAffected product: libgit2. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53585/ (Markdown: https://insights.sbomify.com/CVE-2026-53585/index.md)","id":"CVE-2026-53585","markdown":"https://insights.sbomify.com/CVE-2026-53585/index.md","name":"CVE-2026-53585","record":{"aliases":["AZL-96965","BELL-CVE-2026-53585","DEBIAN-CVE-2026-53585","ECHO-11a9-f023-aa1d","GHSA-27m5-gxxh-x79j","JLSEC-2026-1371","MINI-4vj3-whm6-3845"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Git core library","requires_auth":"none","summary":"Attackers can cause memory exhaustion and denial of service in applications using libgit2 by supplying malicious pack data with oversized delta headers.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Prior to 1.8.6 and 1.9.5, git_delta_apply in src/libgit2/delta.c trusts the attacker-controlled res_sz value parsed by hdr_sz from a delta object header and passes that amount to git__malloc before validating delta instructions. Malicious pack data supplied through git_clone, git_fetch, git_remote_fetch, git_indexer_append, or a local attacker-supplied repository can use a very small multi-level OFS_DELTA chain to retain extremely large allocations and exhaust memory. This issue is fixed in versions 1.8.6 and 1.9.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"libgit2: Unbounded Memory Allocation via Delta Object Result-Size Header","id":"CVE-2026-53585","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":0,"n_references":6,"next":{"headline":"libgit2: HTTP transport can leak credentials to an offsite redirect target","id":"CVE-2026-53586"},"packages":[],"prev":{"headline":"libgit2: Submodule path traversal","id":"CVE-2026-53584"},"products":["libgit2"],"published":"2026-08-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-25","vendors":["libgit2"]},"summary":"Attackers can cause memory exhaustion and denial of service in applications using libgit2 by supplying malicious pack data with oversized delta headers.","url":"https://insights.sbomify.com/CVE-2026-53585/"}