# CVE-2026-53598: Prompty: Arbitrary File Read via ${file:path} Reference Expansion

> Attackers can read arbitrary local files via path traversal in Prompty prompt files, impacting applications using the library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-wxhm-2mq7-7697, PYSEC-2026-3538

## What is CVE-2026-53598?

CVE-2026-53598 is a high-severity path traversal vulnerability in microsoft prompty, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Prompty is a markdown file format (.prompty) for LLM prompts. Prior to 2.0.0-beta.2, Prompty loaders expanded ${file:...} references in .prompty frontmatter without enforcing that resolved paths stayed within the prompt directory or allowed roots, allowing an attacker-controlled prompt file to read local files through absolute paths, .. traversal, or symlink escapes. This issue is fixed in versions 2.0.0-beta.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-53598?

9 open source packages ship an affected version, including prompty, Prompty.Core and @prompty/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prompty` | PyPI | All versions | 2.0.0b2 |
| `prompty` | PyPI | All versions | 2.0.0b2 |
| `prompty` | PyPI | All versions | 2.0.0b2 |
| `prompty` | crates.io | All versions | 2.0.0-beta.2 |
| `prompty` | crates.io | All versions | 2.0.0-beta.2 |
| `Prompty.Core` | NuGet | All versions | 2.0.0-beta.2 |
| `Prompty.Core` | NuGet | All versions | 2.0.0-beta.2 |
| `@prompty/core` | npm | All versions | 2.0.0-beta.2 |
| `@prompty/core` | npm | All versions | 2.0.0-beta.2 |

## How do I fix CVE-2026-53598?

Upgrade prompty to a fixed version for your release line: 2.0.0b2 or 2.0.0-beta.2.

## Is CVE-2026-53598 being exploited?

There is no known exploitation of CVE-2026-53598 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53598 and fix it if it is affected.

What it is: CVE-2026-53598 is a high-severity path traversal vulnerability in microsoft prompty, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53598 in the wild and no public exploit code.

Affected packages and fixed versions:
- prompty (PyPI): affected all versions; fixed in 2.0.0b2
- prompty (PyPI): affected all versions; fixed in 2.0.0b2
- prompty (PyPI): affected all versions; fixed in 2.0.0b2
- prompty (crates.io): affected all versions; fixed in 2.0.0-beta.2
- prompty (crates.io): affected all versions; fixed in 2.0.0-beta.2
- Prompty.Core (NuGet): affected all versions; fixed in 2.0.0-beta.2
- Prompty.Core (NuGet): affected all versions; fixed in 2.0.0-beta.2
- @prompty/core (npm): affected all versions; fixed in 2.0.0-beta.2
- @prompty/core (npm): affected all versions; fixed in 2.0.0-beta.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53598/ (Markdown: https://insights.sbomify.com/CVE-2026-53598/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53598
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53598
- OSV: https://osv.dev/vulnerability/CVE-2026-53598

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53598/
Summaries are generated and may contain mistakes; the official description above is the record.
