{"answers":{"affected":"2 open source packages ship an affected version, including sanitize-html.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53606 exists.","fix":"Upgrade sanitize-html to 2.17.5 or later.","what":"CVE-2026-53606 is a medium-severity cross-site scripting vulnerability in apostrophecms sanitize-html, published on 12 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-53606 and fix it if it is affected.\n\nWhat it is: CVE-2026-53606 is a medium-severity cross-site scripting vulnerability in apostrophecms sanitize-html, published on 12 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53606 exists.\n\nAffected packages and fixed versions:\n- sanitize-html (npm): affected from 1.18.0; fixed in 2.17.5\n- sanitize-html (npm): affected from 1.18.0; fixed in 2.17.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53606/ (Markdown: https://insights.sbomify.com/CVE-2026-53606/index.md)","id":"CVE-2026-53606","markdown":"https://insights.sbomify.com/CVE-2026-53606/index.md","name":"CVE-2026-53606","record":{"aliases":["CLEANSTART-2026-IA44720","CLSA-2026-1786373316","ECHO-be5c-2a34-b344","GHSA-vccv-cmxp-4j9h","MINI-2q2f-pc4v-w45v","MINI-vrpq-f6wx-2mwc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js HTML sanitizer","requires_auth":"low_privilege","summary":"Incomplete URI validation in sanitize-html allows javascript: URIs in specific attributes, enabling XSS if those attributes are explicitly allowed.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"ApostropheCMS is an open-source Node.js content management system, and sanitize-html provides a simple HTML sanitizer with a clear API. Versions of sanitize-html prior to 2.17.5 use `allowedSchemesAppliedToAttributes` (default: `['href', 'src', 'cite']`) to gate the `naughtyHref()` function that blocks dangerous URI schemes like `javascript:` and `vbscript:`. The HTML specification defines 10+ attributes that accept URIs (`action`, `formaction`, `data`, `poster`, `background`, `ping`, `xlink:href`, `dynsrc`, `lowsrc`), but none of these are included in the default gate list. When a developer allows any of these attributes in their configuration, `javascript:` URIs pass through completely unmodified, enabling XSS. Version 2.17.5 patches the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"sanitize-html has incomplete URI scheme validation in that allows javascript: URIs through action, formaction, data, poster, and background attributes","id":"CVE-2026-53606","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"@apostrophecms/file pretty-URL Vulnerable to Unauthenticated SSRF via Host header","id":"CVE-2026-53607"},"packages":[{"ecosystem":"npm","fixed":["2.17.5"],"introduced":["1.18.0"],"last_affected":[],"package":"sanitize-html","purl":null,"source":"GHSA-vccv-cmxp-4j9h"},{"ecosystem":"npm","fixed":["2.17.5"],"introduced":["1.18.0"],"last_affected":[],"package":"sanitize-html","purl":"pkg:npm/sanitize-html","source":"GHSA-vccv-cmxp-4j9h"}],"prev":{"headline":"Reachy Mini Wireless: Local Privilege Escalation via Unrestricted sudo systemctl Grant","id":"CVE-2026-53605"},"products":["sanitize-html"],"published":"2026-06-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-15","vendors":["apostrophecms"]},"summary":"Incomplete URI validation in sanitize-html allows javascript: URIs in specific attributes, enabling XSS if those attributes are explicitly allowed.","url":"https://insights.sbomify.com/CVE-2026-53606/"}