{"answers":{"affected":"2 open source packages ship an affected version, including apostrophe.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53607 exists.","fix":"Upgrade apostrophe to 4.31.0 or later.","what":"CVE-2026-53607 is a low-severity server-side request forgery vulnerability in apostrophecms apostrophe, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-53607 and fix it if it is affected.\n\nWhat it is: CVE-2026-53607 is a low-severity server-side request forgery vulnerability in apostrophecms apostrophe, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53607 exists.\n\nAffected packages and fixed versions:\n- apostrophe (npm): affected all versions; fixed in 4.31.0\n- apostrophe (npm): affected all versions; fixed in 4.31.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53607/ (Markdown: https://insights.sbomify.com/CVE-2026-53607/index.md)","id":"CVE-2026-53607","markdown":"https://insights.sbomify.com/CVE-2026-53607/index.md","name":"CVE-2026-53607","record":{"aliases":["GHSA-34pj-2622-jvxq"],"analysis":{"component_type":"cms_plugin","fix_type":"no_fix_stated","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"ApostropheCMS file plugin","requires_auth":"none","summary":"Unauthenticated attackers can exploit SSRF in ApostropheCMS file plugin when pretty URLs are enabled, enabling internal network mapping and potential data leakage.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"ApostropheCMS is an open-source Node.js content management system. In versions up to and including 4.30.0, when `prettyUrls: true` is enabled on `@apostrophecms/file` (a documented SEO feature for serving uploaded files at clean URLs), the public pretty-URL handler builds the upstream URL using the raw `Host` HTTP request header. That URL is then `fetch`'ed and the response body + headers are streamed straight back to the requester. Because `Host` is fully attacker-controlled, an unauthenticated remote attacker can pivot the apostrophe process to issue outbound HTTP requests against any host it can reach on the private network. The path component is constrained to `/uploads/attachments/\u003ccuid\u003e-\u003cslug\u003e.\u003cext\u003e` (built from a local-DB lookup), which keeps the impact narrow: cross-instance data exfiltration is neutralized by cuid uniqueness, but blind-SSRF residuals remain (network-topology mapping via response-code / timing differences and verbose proxy/WAF 404 body disclosure). As of time of publication, no known patched versions exist.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@apostrophecms/file pretty-URL Vulnerable to Unauthenticated SSRF via Host header","id":"CVE-2026-53607","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"@apostrophecms/seo Vulnerable to Stored XSS via Unsanitized Google Analytics / GTM ID Injected into Script Tag","id":"CVE-2026-53608"},"packages":[{"ecosystem":"npm","fixed":["4.31.0"],"introduced":["0"],"last_affected":[],"package":"apostrophe","purl":null,"source":"GHSA-34pj-2622-jvxq"},{"ecosystem":"npm","fixed":["4.31.0"],"introduced":["0"],"last_affected":[],"package":"apostrophe","purl":"pkg:npm/apostrophe","source":"GHSA-34pj-2622-jvxq"}],"prev":{"headline":"sanitize-html has incomplete URI scheme validation in that allows javascript: URIs through action, formaction, data, poster, and background attributes","id":"CVE-2026-53606"},"products":["apostrophe"],"published":"2026-06-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-15","vendors":["apostrophecms"]},"summary":"Unauthenticated attackers can exploit SSRF in ApostropheCMS file plugin when pretty URLs are enabled, enabling internal network mapping and potential data leakage.","url":"https://insights.sbomify.com/CVE-2026-53607/"}