# CVE-2026-53607: @apostrophecms/file pretty-URL Vulnerable to Unauthenticated SSRF via Host header

> Unauthenticated attackers can exploit SSRF in ApostropheCMS file plugin when pretty URLs are enabled, enabling internal network mapping and potential data leakage.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 15 Jun 2026
- **Also known as:** GHSA-34pj-2622-jvxq

## What is CVE-2026-53607?

CVE-2026-53607 is a low-severity server-side request forgery vulnerability in apostrophecms apostrophe, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ApostropheCMS is an open-source Node.js content management system. In versions up to and including 4.30.0, when `prettyUrls: true` is enabled on `@apostrophecms/file` (a documented SEO feature for serving uploaded files at clean URLs), the public pretty-URL handler builds the upstream URL using the raw `Host` HTTP request header. That URL is then `fetch`'ed and the response body + headers are streamed straight back to the requester. Because `Host` is fully attacker-controlled, an unauthenticated remote attacker can pivot the apostrophe process to issue outbound HTTP requests against any host it can reach on the private network. The path component is constrained to `/uploads/attachments/<cuid>-<slug>.<ext>` (built from a local-DB lookup), which keeps the impact narrow: cross-instance data exfiltration is neutralized by cuid uniqueness, but blind-SSRF residuals remain (network-topology mapping via response-code / timing differences and verbose proxy/WAF 404 body disclosure). As of time of publication, no known patched versions exist.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-53607?

2 open source packages ship an affected version, including apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.31.0 |
| `apostrophe` | npm | All versions | 4.31.0 |

## How do I fix CVE-2026-53607?

Upgrade apostrophe to 4.31.0 or later.

## Is CVE-2026-53607 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53607 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53607 and fix it if it is affected.

What it is: CVE-2026-53607 is a low-severity server-side request forgery vulnerability in apostrophecms apostrophe, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53607 exists.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.31.0
- apostrophe (npm): affected all versions; fixed in 4.31.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53607/ (Markdown: https://insights.sbomify.com/CVE-2026-53607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53607
- OSV: https://osv.dev/vulnerability/CVE-2026-53607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53607/
Summaries are generated and may contain mistakes; the official description above is the record.
