{"answers":{"affected":"2 open source packages ship an affected version, including @apostrophecms/seo.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53608 exists.","fix":"Upgrade @apostrophecms/seo to 1.5.0 or later.","what":"CVE-2026-53608 is a high-severity cross-site scripting vulnerability in @apostrophecms/seo, published on 12 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-53608 and fix it if it is affected.\n\nWhat it is: CVE-2026-53608 is a high-severity cross-site scripting vulnerability in @apostrophecms/seo, published on 12 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53608 exists.\n\nAffected packages and fixed versions:\n- @apostrophecms/seo (npm): affected all versions; fixed in 1.5.0\n- @apostrophecms/seo (npm): affected all versions; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53608/ (Markdown: https://insights.sbomify.com/CVE-2026-53608/index.md)","id":"CVE-2026-53608","markdown":"https://insights.sbomify.com/CVE-2026-53608/index.md","name":"CVE-2026-53608","record":{"aliases":["GHSA-wf43-fpp3-cf65"],"analysis":{"component_type":"cms_plugin","fix_type":"no_fix_stated","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"ApostropheCMS SEO plugin","requires_auth":"low_privilege","summary":"Editors can inject malicious scripts via Google Analytics IDs, leading to stored XSS affecting all site visitors.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"ApostropheCMS is an open-source Node.js content management system. Versions up to and including 1.4.2 of the `@apostrophecms/seo` package injects the Google Analytics Tracking ID (`seoGoogleTrackingId`) and Google Tag Manager ID (`seoGoogleTagManager`) directly into `\u003cscript\u003e` tag bodies using JavaScript template literals without any sanitization or validation. Any user with editor-level access (the default role for content managers) can set these fields to a malicious value, resulting in stored XSS that executes on every page for every visitor of the site. As of time of publication, no known patched versions are available.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@apostrophecms/seo Vulnerable to Stored XSS via Unsanitized Google Analytics / GTM ID Injected into Script Tag","id":"CVE-2026-53608","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Apostrophe has Server-Side Prototype Pollution in apos.util.set via patch operators that leads to process-wide authorization bypass","id":"CVE-2026-53609"},"packages":[{"ecosystem":"npm","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"@apostrophecms/seo","purl":null,"source":"GHSA-wf43-fpp3-cf65"},{"ecosystem":"npm","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"@apostrophecms/seo","purl":"pkg:npm/%40apostrophecms/seo","source":"GHSA-wf43-fpp3-cf65"}],"prev":{"headline":"@apostrophecms/file pretty-URL Vulnerable to Unauthenticated SSRF via Host header","id":"CVE-2026-53607"},"products":["@apostrophecms/seo"],"published":"2026-06-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-15","vendors":["apostrophecms"]},"summary":"Editors can inject malicious scripts via Google Analytics IDs, leading to stored XSS affecting all site visitors.","url":"https://insights.sbomify.com/CVE-2026-53608/"}