# CVE-2026-53608: @apostrophecms/seo Vulnerable to Stored XSS via Unsanitized Google Analytics / GTM ID Injected into Script Tag

> Editors can inject malicious scripts via Google Analytics IDs, leading to stored XSS affecting all site visitors.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 15 Jun 2026
- **Also known as:** GHSA-wf43-fpp3-cf65

## What is CVE-2026-53608?

CVE-2026-53608 is a high-severity cross-site scripting vulnerability in @apostrophecms/seo, published on 12 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

ApostropheCMS is an open-source Node.js content management system. Versions up to and including 1.4.2 of the `@apostrophecms/seo` package injects the Google Analytics Tracking ID (`seoGoogleTrackingId`) and Google Tag Manager ID (`seoGoogleTagManager`) directly into `<script>` tag bodies using JavaScript template literals without any sanitization or validation. Any user with editor-level access (the default role for content managers) can set these fields to a malicious value, resulting in stored XSS that executes on every page for every visitor of the site. As of time of publication, no known patched versions are available.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-53608?

2 open source packages ship an affected version, including @apostrophecms/seo.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apostrophecms/seo` | npm | All versions | 1.5.0 |
| `@apostrophecms/seo` | npm | All versions | 1.5.0 |

## How do I fix CVE-2026-53608?

Upgrade @apostrophecms/seo to 1.5.0 or later.

## Is CVE-2026-53608 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53608 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53608 and fix it if it is affected.

What it is: CVE-2026-53608 is a high-severity cross-site scripting vulnerability in @apostrophecms/seo, published on 12 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53608 exists.

Affected packages and fixed versions:
- @apostrophecms/seo (npm): affected all versions; fixed in 1.5.0
- @apostrophecms/seo (npm): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53608/ (Markdown: https://insights.sbomify.com/CVE-2026-53608/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53608
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53608
- OSV: https://osv.dev/vulnerability/CVE-2026-53608

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53608/
Summaries are generated and may contain mistakes; the official description above is the record.
